Every Netlify Site I Visit Can't Be Reached from the Philippines

I don’t know when this problem started, but out of nowhere, I cannot access any site that has a netlify.app domain.

The error message will always show:

This site can’t be reached

Check if there is a typo in ***.netlify.app.

  • If spelling is correct, try running Windows Network Diagnostics.

DNS_PROBE_FINISHED_NXDOMAIN

I can access the sites with my other devices using the same network. I can’t access Netlify apps using my laptop which I mainly use for coding. I even tried flushing DNS, but no use.

I’m not sure if I’m the only one who encounters this problem, but any help would be greatly appreciated :sweat_smile:

Could you share the URL?

Uhm…no specific url. Just any Netlify app that uses the netlify.app subdomain.

That’s not the case at least for me. Most sites appear to be working fine, which is why I asked if you’re having issues with a specific URL.

For example these demo sites:
https://share-me-sanity.netlify.app/

https://vitesse-nuxt3.netlify.app/

Appears to be working fine:

Could you try using a different ISP?

That’s the thing, on my phone, I can access the sites using the same network.

If you can access using the same network, then there’s something wrong with the configuration on your computer. It could be bad DNS settings, firewalls, hosts or anything else.

Hello I am currently experiencing the issue above, sites that uses

netlify.app

is not accessible/working on other ISP.

Using VPN and other ISP works or weird is the app is working on my mobile browser but not on my desktop. Is there any solution that I can do for this?

Hi @redmg

If you are able to access .netlify.app sites on a mobile device but not a desktop, using one network provider but not another, then it is highly likely the issue is a device or network-centric one and not anything to do with Netlify (either in terms of not working, or blocking traffic.)

1 Like

Hey @redmg :wave:

It would also be helpful to know where you are connecting from without the VPN! This will help us investigate any trends.

Let me know if you feel comfortable sharing this!

I have the same issue and I am not using any VPN. Haven’t touched any DNS setting on my mac.

What is the site, or are the sites, you are unable to access @jdmanabat? Have you tried using different browsers, different devices, and/or different networks?

hi there @jdmanabat - are you based in the phillipines? if yes, can you tell us what ISP you are using to access the internet (without a VPN)?

Hi Perry, I’m from the Philippines and also experiencing this on my project - https://nagrand-hotel.netlify.app/. My ISP is PLDT and project is accessible when using VPN(NordVPN).

hi to everyone on this thread -

we have looked into the issue and it seems that there is nothing on our end that is causing the problem, but i can confirm that we are having multiple customers from the phillipines who are experiencing this issue.

it seems like one or more ISPs from your area are banning access to netlify sites for an unknown reason - it is possible that there was something on our service at some point that they didn’t like - but we have no further information at this time when this ban occurred or what the reason behind it is.

As we don’t have a way to speak with internet service providers directly, the best and only option that really exists is to reach out to your internet service provider and try and get them to investigate the issue - i know that seems circuitous but it is the best advice we have at this time.

If your ISP needs to get in touch with us to discuss anything related to our service, we can make that arrangement. I’m sorry i don’t have better news!

3 Likes

Thanks for the explanation. I’m going to reach out to PLDT (both in twt and email (if I found an email)). I’ll send this thread. Best if I can include netlify’s contact info should they intend to respond. What netlify email should I include? Thank you

hi there,

i am going to sed you a DM with some special contact instructions in just a moment!

thank you for trying to help us!

Hello guys, I’ll be able to access my Netlify site by adding a Google DNS on my machine and it worked. You can try it if it works on your end. Thanks.