Error: This site can't be reached

Site name: https://heartfelt-lokum-a3378f.netlify.app/
Custom domain: johnnyforschoolboard.com (Registered with GoDaddy, converted to Netlify DNS

The website, seemingly only for me, continues to switch on and off between showing up correctly or showing an ERR_CONNECTION_REST This site cannot be reached , The connection was reset, error. Sometimes it works, but other times it goes back to this and it has cycled between them about 3 times now.

I am new to all of this, so what I know I did, and this is all, is copied the four name servers from Netlify into my GoDaddy DNS page. I skipped the optional step to copy DNS records as I didn’t have anything with email so I figured it would be fine to skip. Another post, This site can't be reached , suggests that there is a CNAME record I should delete, but in my Netlify DNS Settings, there are only two DNS records, one for the domain name and one for www domain name.

Other people have said it is working consistently for them, but me and my roommate keep having it cycle between on and off. The nameservers were changed roughly 2 hrs 45 mins ago, and Netlify says that HTTPS is enabled and that a certificate for SSL/TLS is there and was created at 5:45 PM CST (almost 3 hours ago and matching closely with when I changed the nameservers).

I have tried to clear my cache on Chrome and that initially fixed it but then it stopped working again. It also does not work on Edge of my mobile device running Chrome or Safari. The address to the netlify site and not the custom domain is working, so I suspect it must be something weird with a DNS record or caching or something of the sort, but I am stuck on where to go from here.

Someone else in another article recommended to put a CNAME file in the repository, but were very vague with what to put in this file, and suggestions for how to go about fixing this? As of posting this, it is not working for me or my roommate.

The site does appear to work fine for me too. Are you sure this is not just local DNS propagation issue?