Problem Adding Custom Domain - Another site is already using

Hi there. I have added a TXT record on Hover. What do I need to do now to verify ownership of my domain on netlify? Please help

Hi @Fernando_Arce,

I’ve responded to your other post here:

Please let us know in that post the custom domain you’re trying to add and the site you’re trying to add it to. We’ll then be able to verify the TXT Record. Thanks!

Hi Melvin,

Thanks for responding. and sorry for my sloppiness. I’m not a tech-person!

The custom domain i want to add is

and trying to add it to the site: (that’s the “subdomain” as i undrestand it?)

I hope this is the info you’re asking for?

Please let me know.


Hi @Fernando_Arce :wave:t6: can you follow the instructions in this support guide. Once this is done please come back and verify and we will release the domain from the other account.


I believe I followed the instructions. Not sure if I am missing something.

I wen to my domain host (Hover), and added a TXT record. In the “content” box I wrote verified-for-netlify. In the “host” box I wrote @. TTL I left as default.

I’m not sure if I’m supposed to do anything else.

My custom domain I want to add is

The netlify domain under which the site “deploys” is

Please advise if this is not what you are looking for.

Thank you

Hi @Fernando_Arce,

Looks like you’ve added the domain already.


Yes, I received a message the domain had been removed from the other site, so I went and tried to follow the instructions and seems like I have done it, because the website and domain are working properly.

Thank you and to everybody for all your help!

Hello. I’m having the same issue for domain
I have added a TXT record on godaddy.
please verify my ownership.

Hi @jeongho,

Thanks you for reaching out! I’ve verified and you should be able to use the domain now.

Hello Netlify team,

I’m facing the same issue. I have already deleted the DNS domain on the other account, but I can’t the domain on the new account, it’s always saying “ or one of its subdomains is already managed by Netlify DNS on another team.”.

My domain is and I already added a TXT file on hostinger. Please help me, I want to use the domain on the new account.

Hi, @Mussassa. Thank you for creating that verification DNS record. Please feel free to delete it anytime now that the verification is complete.

The DNS zone has been removed from the other team now. ​Please let us know if there are still errors when adding the domain to the new site or team. (There should not be but, if there are, we’ll be ready to keep working on this.)

i have isssue in add custom domain of go daddy is already registered. If you registered this domain name through a different registrar, select Add domain to begin delegating it to Netlify.

kindly remove from my account so i can add again to deploy my site

Can you please create a verification DNS record these steps here.

my domain is having the same issue

Hey there, this is happening because the custom domain you’re trying to use already exists on Netlify under a different account.

If you have some idea of who might be using the domain (maybe a previous collaborator or an agency you’ve worked with in the past?), the quickest way to get this resolved is for you to contact that person directly and ask them to remove the domain from their account here:

Netlify App > “Options” dropdown > “Remove domain”

If you’re not sure, please verify domain ownership and let us know by responding here when that’s done. If the verification is successful we can remove the domain from the other account so you can use it on yours.

I have just bought the URL. I don’t know who the previous owner is.

@tmoodley This is a live site and we need we’ll need for you to verify that you have control over the custom domain. You can follow this Support Guide:[Support Guide] "another site is using this domain" Verifying domain ownership for Netlify production domain

When you verify the txt record please write back.

I have updated to txt record for

Hi @tmoodley

Thank you for verifying domain ownership. We have removed the domain from the site that was using it. Could you try adding it to your site now and let us know if you’re still running into trouble?

Same issue with “” domain