Slow load time for Gatsby site

I’m experiencing similar behaviour with a newly deployed gatsby build. I’m seeing some assets take the same (long) time to load. For example there are 6 files (a few js files from the gatsby build, a webpack js file and a page-data json file) that all take exactly 33.41 seconds to load, another batch of 4 similar files all take 25.19 seconds. This is all the case when checking on wifi, checking on a cellular 4g network the performance is normal/as expected.

Hoping to find our some more information if possible

Hiya @Jwrighty - your issue is unlikely to be related to the thread you posted in, so I moved it over here where we can talk about it in depth.

Could you tell us what site you’re talking about, so we can look into it?

Hi there, apologies only just seen this and sorry if it wasn’t relevant to the post!
The site is

Seen on other posts that a har file may be helpful to investigate:

hey @Jwrighty, we are still looking a this internally, but at the moment we aren’t quite sure what is causing the behaviour that you are describing. Doesn’t mean it’s not happening :slight_smile: but we’re not sure what is causing it.

Are you seeing this consistently?

hey @perry, yup still getting the same pretty consistently. Whenever i run on a fresh browser/incognito, basically whenever it doesn’t have the image cached they take a long time. Have tried across different browsers.
Also tried deploying to a fresh site and get the same results. And i’m getting it when loading over a cellular network now too.

Is there any additional information i can provide to assist investigation?

Please note i’ve had to redirect the domain listed above to different hosting for the minute (which coincidentally doesn’t show this issue) but the netlify hosted version is at

Thanks for your patience - we’ve been looking into this and it is quite odd - your HAR file shows very different timings than our servers in sending the content. I suppose that you would have said something if other websites like google were also behaving super slowly from your network as well? Did you ever try from a different network or browser just to rule some local configuration out? I know the new host doesn’t show the problem, so I am not trying to blame your site layout, but I am trying to eliminate possible points of failure.

Also related: do you still see the bad timing on the netlify hostname?

Weird indeed!
I’ve not seen this behavior on any other sites
I’ve been able to replicate on both my home and mobile network. On mac - chrome/firefox/safari, windows chrome/firefox and iOS chrome/safari. All tested running incognito / clearing cache
And yes it’s still on the netlify hostname, even tried redeploying to a new one and i’m still experiencing the same.

Here’s a comparison of the gallery page load, both run on the same network on chrome in separate incognito windows. Quite the significant difference.

Well, shoot, my team has spent a couple hours looking at this now and we aren’t able to reproduce your situation. What we can see is some mild slowness - ~1s - on account of your gallery page loading dozens of webp files simultaneously - but nothing like the 10+s that your screenshot and your HAR file show.

We can see some slow loads in our internal logs - but in ALMOST all of those cases, the “slow” was SO slow that the browser hung up without completing the transfer - which is NOT what your screenshot or HAR file showed, so none of those requests would have been you. All completed requests completed in well under 5 seconds from our side.

I’m kind of grasping at straws now, but is it possible that your computer has something like a proxy or VPN running? Do you see similar behaviors on other computers entirely, that wouldn’t necessarily have something like antivirus or a proxy even potentially in the way of these network requests?

Yeah i had tested on a macbook and a separate windows laptop which was a brand new build with no proxy or vpn set up.

Have checked across a few devices this morning and i’m seeing a significant improvement, not sure why though have only made some small styling and seo updates on my end :man_shrugging:

If you’re unable to replicate and i’m seeing improvements we may want to close off this issue, i’ll monitor for a few days and if i see it comes back and will re-open with any new info i have.

Appreciate the time taken to investigate, if there’s any other info i can provide let me know.

1 Like

sounds good @Jwrighty. If you are able to reproduce, let us know. I’m going to close this thread as we’re not sure what is happening here, exactly, if you do see the issue again please start another one and link to this one :slight_smile: