Problem Adding Custom Domain - Another site is already using

Hey @LI-Huabing,

The domain has been removed from the other site.

Hi Hrishikesh, I’m having the same issue for domain uribedav.com. I get the message - uribedav.com is already registered. If you registered this domain name through a different registrar, select Add domain to begin delegating it to Netlify.

Hey there, @dave1 :wave: welcome to the Netlify Forums.

this is happening because the custom domain you’re trying to use already exists on Netlify under a different account.

If you have some idea of who might be using the domain (maybe a previous collaborator or an agency you’ve worked with in the past?), the quickest way to get this resolved is for you to contact that person directly and ask them to remove the domain from their account here:

Netlify App > “Options” dropdown > “Remove domain”

If you’re not sure, please verify domain ownership and let us know by responding here when that’s done. If the verification is successful we can remove the domain from the other account so you can use it on yours.

I’m facing the same problem. tusharhasan.com is already registered. If you registered this domain name through a different registrar, select Add domain to begin delegating it to Netlify.

Please solve this issue.

Hi hillary. I also face the same problem with the domain noht.co.jp, and the TXT record has been set according to below url. Please let me know if anything else is required.

Anyone experiencing this issue should show support for it being made something you can self-service:

hi there, sadly i couldn’t find a verification record for this domain, did you try and create one as per this guide?

hi there,
could you try again, and if it does not work to add the domain, could you please grab a screenshot and comment here with that screenshot? thanks!

Thanks
Here is a screenshot of the Netlify configuration page and the AWS Route53 configuration page. Please tell me how to reset it.

hi there, have you tried clicking “add domain”? what happens? thanks.

Hi there I’m having the same issue with domain geniuzedu.com.br
Telling me that custom_domain is owned by another account.

Can you help me please!

hi there, did you make a verification record as per this guide?

Yes I asked the other account (collaborator) to delete the domain and he did. He also deleted the app just to be sure and I still have the error custom_domain is owned by another account.

Site name: geniuzedu

Thanks for the quick reply!!

I’ve done all the steps:

  1. asking collaborator to remove de domain
  2. Add TXT record

Can you help me with this?

Best regards!

Hey @ajunior,

The domain has been removed from the other account.

Hey there, I am facing the same issue. please check my this post.

verify my domain ownership

This has been solved there.

It seems that it was a misunderstanding. Now it’s settled. Thank you.

1 Like