Primary domain says "Check DNS configuration", but DNS configuration looks correct


I have a domain, configured for the site The site is up and running, and a DNS certificate was issued, but I can’t get to the site from my domain. The domain settings screen for the site says “Check DNS configuration”, but on the DNS page, it just says it’s configured for that site with Netlify.

EDIT: Adding more detail to figure out how we got here:

Before Netlify, I had three versions of the same website: (“main”),, and We migrated alpha first, setting it up on, and transferred our DNS nameservers over to Netlify, and set up an A record for and a CNAME for beta to point both of them to the old server. This went very smoothly, alpha was working, and so was beta and the main site.

(I have to remove .com here because it won’t let me post more than 6 links)

Then we attempted to migrate finalfantasyrandomizer, and that’s when we saw the “Check DNS configuration” message. In the DNS panel, it still showed the A record that I had set up, as well as the new Netlify configuration, so I removed the A record. That didn’t solve things, so I unregistered ecstatic-colden from finalfantasyrandomizer entirely. I noticed that when I did so, it did not remove itself from the DNS panel, and it wouldn’t let me manually remove it. I re-registered ecstatic-colden for finalfantasyrandomizer, but we’re still seeing the same message.

@Entroper OK, I see that you have Netlify DNS for, but it appears that you have something else set as DNS for At your registrar (GoDaddy), the only DNS records you should have are where you assign DNS to Netlify.

Can you confirm that as the case?

Also, in the Netlify DNS panel, you should not have a separate A record entered. Can you confirm that?

Finally, on the Domains page of ecstatic-golden…, you should have the finalfastasyrandomizer domain name linked, as well as the www.finalfantasyrandomizer subdomain. Can you confirm that?

At GoDaddy, the only records I have are the NS records for Netlify, as far as I can tell. Once you change your nameservers, GoDaddy just shows you a page that says “we don’t control your domain” with the option to reassign nameservers, it doesn’t show any other records.

If I do a curl -I, it shows Netlify as the server and redirects to the base domain. So I think that’s okay.

Here’s my DNS panel at Netlify:

We do want to eventually migrate beta to Netlify, but I need an application server for the co-op application, so that needs to go elsewhere. Will that still work?

@Entroper Maybe try removing the link between the finalfantasyrandomizer custom domain and then re-adding it? I dunno, I’m out of ideas. Sorry.

We tried that. When I remove the domain from the site, the DNS panel still shows the same thing – no changes. So it’s not actually removing the DNS configuration that it has.

I think I’m going to delete all DNS configuration and start over.

EDIT: Yeah, that finally, eventually worked. I had to delete the DNS domain completely, but it was still messed up when I set it up again. The sites needed to also have their domains removed separately, then I could start completely from scratch. Seems to be working now, hope it stays that way!

1 Like