Netlify Identity Widget Invite Link Issue

My registration is invite only. When new users click “Accept Invite” in the invite email you briefly see a flash of the gray overlay but then it just loads the home page with no option to verify the email or set a password. I have the Netlify Identity Widget in the head ( src=“” ) and I can see the iframe for the widget when I inspect element.

Months prior, before I switched the site to a custom domain, I was able to send and act on invites. I am not sure if I changed settings or created some other issue or if something else is going on. I appreciate any tips or help. Let me know if there are details or information I can provided. Thanks!

hmm, interesting. Does the widget behave the same in every browser? what about in an incognito window? the reason I ask this as there are some browser extensions that can cause some not-as-intended behaviour, and what you are describing sounds like similar.

Thanks for the quick reply. I’ve tried is Safari, Chrome, Firefox and Brave in incognito and out. I still can’t verify the account and add a password. It gives me the flash of translucent gray and then loads the home page. Do you have any other ideas? I am trying to create logins for my client, but they’re not able to verify their accounts.

Could you tell me what you site name is? I can check to see if there is some sort of syntax or loading error. Also, it’ll be easier to determine the issue with I can poke at the issue directly. Thanks.

Thanks Dennis, the site is:

Hi, I’m not sure what is causing the identity widget to fail to load. Perhaps, your javascript app is overriding the visibility of the iframe. Do you know the exact deploy where the issue started happening?

Also, using a custom domain will very probably not cause the widget to stop working. So that isn’t a factor.

OK, I was able to resolve my issue. Some other script must conflict with the Identity script. So I created a separate basic html page page just for Identity invites, confirmations, and password changes ( Then I created new Identity email templates to point to that page instead of the homepage ( And it works!

I didn’t figure out what script was causing the issue, but I solved my problem for now.


1 Like

great. thanks for posting your solution - that will definitely help other people! :slight_smile: