My netlify site is now showing not secure

Hi to the forums,

Three of my Netlify deployments are now not secure/not serving over https and are throwing a “Your connection is not secure” error in the browser (Chrome, Brave, Safari). This problem wasn’t happening until recently. Each deployment is for dev/demo purposes and uses a default Netlify subdomain. In each of the site domain settings under HTTPS it says “Enable automatic TLS certificates with Let’s Encrypt, or use your own certificate” (there appears to be no automatic TSL cert being applied), and then under SSL/TSL “A custom domain is required to provision a certificate. You’ll need to set a custom domain before you can enable HTTPS.” Which seems contradictory.

How do I get my sites rendering properly with SSL/TSL - and has anything changed with default Netlify deployments not using free/automatic SSL certs? I have a free tier account, and two of the sites in question are, and

Thanks in advance for any/all help.

Hi @masonmedia, your site is secured with HTTPS when I visit it. Is the problem resolved?

1 Like

Thanks for the reply. I just checked the two links: they do not work in Safari or Brave. They do however now work in Chrome (didn’t as of earlier this morning).

The site is working on Brave mobile, will check brave desktop when I am at my computer. Can you elaborate what you mean by “the links do not work”? Are they throwing an error?

In Brave - I see the urls are rendering/connecting correctly on Brave mobile - but not on desktop sorry didn’t specify. On Brave desktop I get this error “Your connection is not private
Attackers might be trying to steal your information from (for example, passwords, messages, or credit cards). Learn more

In safari, this error: “Safari can’t open the page…because Safari can’t establish a secure connection”

Peculiar, could be related to DNS propagation. Have you tried clearing cache and site data?

1 Like

Hi again,

Just tried again in Brave and Safari desktop and it still throws a not secure/can’t establish connection error " Your connection is not private". I cleared browser cache, hard reloaded, still get the same error on reload. I deployed the same project to vercel and it loads/renders correctly/as intended. I deleted the site completely from my Netlify account and redeployed but still results in the same not secure error.

It’s a subdomain, I don’t see why you would see the error. In any case, that does sound more like a local issue than Netlify since all Netlify sites are loading fine with HTTPS at the moment.

Here are screens of what I’m seeing in Brave desktop (just refreshed, cleared cache and data).

I don’t see why it would throw an error either, but it is - which is why I’m asking for help. This has never happened to me since using Netlify (couple years now), which is why I’m not sure what’s going on.

Safari desktop…

As mentioned, this is something relevant to your local configuration, not a Netlify system issue.

Facing the same issue on my netlify website. On Opera, Chrome, even in Incognito.

  • Free tier account website.
  • Worked well till 2 hrs ago.
  • Suddenly stopped due to above error.
  • No custom SSL setup, had default Netlify one.
  • Certificate is still valid for few more days, but as per error the Authority is Invalid.
  • Cleared Cache and history as well.

@masonmedia I can see your website loads fine. How did you fix it? Did it fix automatically after some hours?

Hey @piyush-mishra-pm – my sites continued to throw the same error until I gave up trying to debug and redeployed both sites on Cloudflare Pages - successfully, with the same exact repos, same setup, same config etc., nothing different from what I had on Netlify. I never went back and checked my netlify deploys until I saw your message. I did nothing, changed nothing to fix them. Netlify support continued to tell me it was a problem on my end, which wasn’t helpful and which I couldn’t find. I see your app seems to be loading as well – did you get any kind of response or clarification as to why or what happened?

1 Like

Your site loads fine for me @piyush-mishra-pm. Last week, I was facing this issue for all subdomains myself. I debugged and found out, I was using AdGuard which was doing something funny with my network configuration, causing it to fail.

You should check your local configurations as well, especially apps that modify network requests like antivirus, or proxy,

1 Like

@masonmedia and @hrishikesh

Thanks for your suggestions. Website started to load today automatically. Everything is working! :smiley:

I don’t think issue was on Netlify side. As I faced this same issue when I deployed same frontend also on Render on 2 days ago (Backend was also deployed there earlier). And today it works on both Render and Netlify!

Must have been something in my browser (Chrome and Opera, etc.). I used incognito too, so extensions might not be likely.

Will also keep your suggestions in mind, if this comes up again!

Thanks for sharing this information with us!

@piyush-mishra-pm glad it’s working. For anyone experiencing the same problem, I never came to a conclusion on what happened or why. A week or so after contacting the forums, my sites just suddenly started loading poperly as expected. I didn’t change any config, didn’t change anything in my code, didn’t change anything in my browsers or browser settings. Because I needed the sites to be live with no problems, I ended up deploying them on Cloudflare Pages – which was successful in all instances, with the same Github repos I used on Netlify, same code, same config, no changes to anything.

Hi, i have the same issue with my website, create for a guild in wow, which they are using. The sertificate is active, but when i try to access the website from my phone 4g i get that i cant access it cause its not secured and when i try to do it with incognito mode on my chrome it works with same internet, this should not exist as a problem i dont know what to do, cause i’ve read all the comments and it seems its not netlify issue, another problem is that most of their clients can’t access it cause of the same issue, and they’ve been complaining to me about it and i can’t figure out how to fix this issue. This is the website it has a custom domain aswell.

Hi there, is this still an ongoing issue? I just accessed the site and see the SSL certificate is working:

Try re-viewing it in a new incognito window (After closing all your other incognito windows) to see if it was a cache issue for you.

for me at home its fine, it is working people are complaining from some countries like Norway, Greece, Sweden, Denmar, im saying some people are complaining, most of the time is working, but why they are complaining, and as i said when i try to access it from my 4g phone internet the site is not secured, i thought its the dns addresses are not properly setup, but thats fine. It might be their problem. Im not sure. Thanks for replying.