Site not loading (DNS or SSL issue maybe?)

Hi folks,

I went to load a site just now and noticed it failed to load.

On Firefox I get “Secure Connection Failed”. On Chrome (and Chromium browsers) I get a blank screen (although the address bar seems to suggest the certificate is valid). On iOS Safari the message is “Can’t open the page because the connection was lost”.

Because Firefox mentioned “secure” I’ve tried to renew the LetsEncrypt cert - although it doesn’t seem to have helped.

I’ve tried redeploying the site, without success (but the build and pipeline appear to run fine)

Finally, I tried renaming the URL to see if it would somehow nudge it into action, but still nothing.

The custom domain URL is, but the URL also isn’t working, which suggests it’s not a custom DNS issue, but instead something rooted at the Netlify end:

I have a couple of other site in the same account running as https://[xx] subdomains, and those are working fine - it seems to be just the root domain with issues.

Any ideas what else I can try to fix it? Short of deleting and setting it up from scratch I’m out of ideas and I’ve never seen this before!


This seems to have fixed itself overnight, so I guess it was just a temporary issue!

The SSL certificate was likely waiting on DNS propagation, glad to see it’s all working now!