Login issue: invalid authorization code

Hello, I’m having difficulty accessing my account… sort of. I believe I initially setup my Netlify account using my GitHub account to login, and it was good for a time. I recently tried logging in to Netlify using the GitHub option and was redirected to here which said “Invalid authorization code” and prompted me to enter my email address and get a new link. I follow the process, reset my password (not sure I had one initially), and login using my email now instead. I’m greeted with a blank page, my sites nowhere in sight; if I go to my user settings it says I created 5 sites, which is probably the right number. Seems like I’m logged into some sort of freaky deaky alternate account that exists on the same plain as my main, my email and github are correct in the settings. In my research to resolve the problem myself I came across this issue report which describes my experience up till we deviate and I can actually login, however I can’t see my sites, and the interface seems broken, as I mentioned before. I considered deauthorizing the GitHub authentication, but don’t want to damage things further, and thought I should ask for help first.

I’d really appreciate any help resolving this, thank you! Also, thank you for freely providing this fantastic hosting service to hobbyists like me!


(The page I see at login)

Hi @aDENTinTIME ,

I’m sorry to hear you’re running into this. I was not able to reproduce in Firefox or Chrome, so I’m wondering if you could share more information about when this occurred. Typically, we hear about things like this due to browser extensions or office firewalls. Is this happening on multiple browsers? Could you try disabling any extensions you’re using? Or see if you experience the same issue when connecting from a different network?

2 Likes

Hi @Melvin,

Thank you for your expedient response! I’m using Safari Version 14.1.1 (14611.2.7.1.6), running on MacOS Mojave 10.14.6. I tried disabling any browser extensions in my troubleshooting and the issue was not resolved. I’m kicking myself for not trying a different browser, I just used FireFox and it appears to be working there, so that is an excellent stopgap, thank you! In the past I’ve used Safari without issue, is this a known problem, if not should I file a bug report somewhere?

Hi, @aDENTinTIME. From what I’ve seen, Safari has unusual caching behavior. By “unusual” I mean that it doesn’t match the behavior of other browsers.

If you clear the browser cache on Safari, it should resolve this behavior there as well. If not, please let us know.

Hi @luke, that was part of my initial troubleshooting, and it failed to resolve the issue (which I neglected to mention). I tried again just now and can confirm that it’s not working in MacOS Mojave 10.14.6 using Safari 14.1.1 (14611.2.7.1.6) or 14.1.2 (14611.3.10.1.7). I tried on another Mac however, this one running MacOS 11.6 using Safari 14.1.2 (16611.3.10.1.6), which did work.

Hmm, well, you could try capturing a HAR file (HAR Analyzer), I suppose, and we could try submitting a bug report using it. Make sure you use specifically this feature, which will hide any authorization tokens which will otherwise be included in the file! I think this workflow will do that (ensuring you do it in a private browsing window: Generate and Analyze HAR Files).

I am not certain we’ll find a fix, but that would be what we’d need, to see more about what you are seeing and get a bug filed if you want to try to keep using the broken browser.

I just took a quick look at my generated HAR file and can’t confidently say that I’ve removed all sensitive information. I leave in a few hours to go traveling sans-computer, so I’ll have to lay this minor issue to rest. Thank you all for your help! Should I mark @Melvin’s response as the solution to clear this ticket?

1 Like

I marked Melvin’s comment as the solution on your behalf. Thanks for following up!