Is there a way to add the NETLIFY DNS records back?

Hi there,

I was attempting to connect my site to Hashnode and was prompted to add an A record and a CNAME however, I was getting a conflict from the NETLIFY and NETLIFYv6 DNS records. I thought I could delete those, add the 2 Hashnode records then add back the Netlify ones. Of course, I can’t seem to find a way to do that.

Is there a way a support engineer would be able to help add these records back or would I be able to delete the domain and add it back? (I haven’t been able to find a button for deleting the domain)

Thank you!!

I saw someone else experience this recently.

It doesn’t seem to be self service, you have to wait for support to perform it.

Hey there, @alexwhitmore :wave:

Thanks for reaching out! Can you please share the site ID of the site you were attempting to connect? That will help us look into this further.

Hi there,

Thanks for getting back to me! My site id is: 8d0b415d-aaff-4cd7-9abe-3b991320862d.


Hi, @alexwhitmore. When this happens the solution is to remove the domain for the site’s custom domain settings (found under Site Name > Settings > Domain management > Custom domains). Then add the custom domain back again in the same site.

Doing this will recreate the missing Netlify type DNS records. If that doesn’t fix it, please let us know.


Hi Luke,

That worked, thank you so much!


I ran into the same issue, but when following these steps, my site still does not want to launch. I have the NETLIFY and NETLIFYv6 DNS files, yet nothing seems to work

hi @Spazdude2

Welcome to our forums! Since you tried to remove the DNS records and putting the back on, what records does your DNS Zone have configured now?

Hello! Same problem as OP but this doesn’t work for me sadly… Any other recommendations?

Please let us know the domain @oujii.

Ah! it’s

7 Jan 2023, 15:14 by

Hey @oujii,

We’re having some issues with our backend when trying to restore the domain. We’ve let the backend team know to fix this as soon as possible.

Highly appreciated! Thank you.

7 Jan 2023, 17:32 by

Hello again! It seems like my Netlify records are back. However, now it says that my domain is registered externally but I’m sure that I registered via Netlify. The notification I get is that the nameservers aren’t Netlifys. Not sure how to fix this – perhaps make a new site and add the domain then would help? Any suggestions would be highly appreciated!

Hey @oujii,

This should now be fixed for you.

Hello again, sorry to bring you bad news. Yes now it is fixed, it says it comes from Netlify, but now it’s been stuck in “Waiting on DNS propagation”…

11 Jan 2023, 13:15 by

Sorry about that. That’s fixed for you too.

This worked for me too - thank you!

I made the same mistake of deleting the Netlify records in DNS settings but this fixed it :pray:t3:

Hi @hrishikesh ,

I am currently experiencing the same issue and cannot recreate the domain because I have a large number of records already in the domain. Can you help add it manually, please?

I would like to add an A record for my domain to site ID: a21fa1f3-77f8-4af8-b067-a8c69b76a9d5

Thank you!


It’s not completely clear to me what you are trying to accomplish. I looked at that site and it does not have a production domain configured. If you add the domain to the site, it will automatically create some Netlify records. That would be the first thing to try. After you do that, are you seeing the records you need?