Host domain on Netlify and subdomain on shopify

Netlify site name:

My domain was working well with Netlify, had it set for to take you to the main page and takes you to design. I want to introduce which takes you to my shopify page, hosted by shopify. This works fine however now the Netlify part of my site doesn’t work. It says Netlify is awaiting me to set the name servers from my external provider but I didn’t change this and my external provider has had the netlify name servers all this time. All that I did in regards to shopify was connect the subdomain and add the a name and c name to the dns settings for the domain on Netlify. Any ideas? Thanks

Can you provide a screenshot of the Netlify DNS records and custom domain settings for the site @bystphie?

The reason the domains are showing Awaiting External DNS is because you have deleted the the NETLIFY records leaving only the NETLIFYv6 records.

For more information on what these are read [Support Guide] What are the NETLIFY and NETLIFYv6 type DNS records? How do I delete these records?

You have two options:

  1. remove and as the production domain, then reassign it. This will recreate the missing records.
  2. Wait for a member of Netlify’s support team to recreate the missing records for you.

Also note the record for will not work as is not a valid value for a CNAME record.

Also note, you should only have an A or CNAME record for, not both.

Thanks so much! I’ll try this later

I deleted all the of the DNS records to try and start from scratch and I can’t remember what record I had for to redirect to /design, any ideas? Thanks again

You could consult the screenshot you posted previously. However, as I noted in my last post, the CNAME record for was not valid. A CNAME (or Canonical Name) record is an alias of one domain for another e.g.

NAME                TYPE    VALUE    CNAME

If you want to redirect to you will need to add as a custom domain to the same project as Then you will need to add a _redirects file in the publish directory of the project (see documentation) e.g.*  301!

I deleted it all before posting and stupidly didn’t take a screenshot, can’t remember what it was but it did used to work, I have found another solution which I think will work

You mean this?

$ dig	4502	IN	CNAME

No, it won’t work. What will work is the solution I offered in my last post.

Thank you this has worked for me, but do you have any idea what I did last time that I deleted? It kept as the url which isn’t essential to me but I did prefer it. Or is there another way to keep that in the url bar?

This is possible, but is usually done in the revere of what you want using and proxy. Not guaranteed to work.

I suggest living with the redirect is the simplest option. Many people won’t even notice the redirect has taken place so won’t know the URL shown has changed.

1 Like