Deployment is not happening and even not showing any errors

It’s been 4hrs since I have been deploying my project but still showing uploading the project at production level … What could be the possible reasons could anyone please help me in that to go through it …

@Aakash231217 What type of deployment have you done?

Drag & Drop, Deployed via CLI, Git Integration?

A simple react app with rapid api in it and I have done it through build folder by running npm run build

That’s fine, but how are you deploying the files to Netlify?

I can’t tell from your description which of the different ways of deploying a project you’re using.

Just using the simple drag and drop

The “Drag & Drop” method isn’t foolproof.

It has several known issues and situations under which it will fail “silently”, and it is considered the “least-desirable and least-capable upload method” by Netlify.

You should use the Netlify CLI if possible, as it’s a core part of their system and better supported.

You can read more about it here:

I have deployed at 2.56 AM and yet it’s 9.56 AM NOTHING SHOWN here and still in the production or deployment environment

Yep, that’s just typical of the “Drag & Drop” method failing.

It can be due to things like the size of the upload and the stability of your own internet connection.

Hey there, @Aakash231217 :wave:

Thanks for reaching out about this. Have you been able to deploy via the CLI? Are you still encountering obstacles?

Please let us know!

No still the same problem

Have you tried deploying with the Netlify CLI or are you still trying with “Drag & Drop”?

Yes with netlify CLI too

@Aakash231217 What error (if any) do you see when attempting the upload via the CLI?

It is showing the page link is broken when I used to submit it with CLI

Your original issue was being unable to upload via “Drag & Drop”.

Now it now sounds like you have uploaded successfully, but that your site/package structure isn’t correct, so the site is showing a 404 when you try to load it, is that correct?

Don’t know actually about that but the same site i have uploaded through vercel now and it’s running perfectly fine

That’s great, obviously the project works, but it doesn’t really have any bearing on “what you have deployed with the CLI on Netlify.”

It’s possible that the Netlify CLI is deploying the entire project and not the correct deploy directory for your project, if you haven’t already see: