Cannot connect to GitHub with OAuth -- maybe due to old account?

I’m having trouble creating a “proper” connection with Netlify and GitHub. I click ‘New site from Git’, go through the GitHub OAuth process, get to the Authorised screen; and I think the 3 step process should move to step 2, but it doesn’t. That’s on my third try.

My first try, however, was a bit weird. I got the Authorised screen immediately, but don’t think I’ve ever connected this account to GitHub before.

It might be because I have another, older account with Netlify that I connected to GitHub. I’ve disconnected and revoked all my Netlify-GitHub connections, at GitHub, but that hasn’t worked. The same problem persists: no step 2 in the new site process.

I’ve tried disabling tracking protection on both Netlify and GitHub, in Firefox, in case that’s blocking necessary cookies, but I don’t think has anythng to do with it – does it? Either way, that didn’t work.

Can anyone help? This is blocking me from publishing my site for now.

I got it working with Edge, for now; so I’m guessing there’s an issue between Netilfy and Firefox, or at least my Firefox setup. I don’t have NoScript, and have tried setting tracking protection to Standard.

I get stuck at the Authorised screen with no redirection.

i would try this again but first making you sure you don’t have any browser extensions running. Sometimes adblockers or other extensions make things act erratically.

the fact that this works with edge is making me think this might help.