Website returns DNS_PROBE_FINISHED_NXDOMAIN but nameservers are good with whois


I have a custom domain name that I bought on

I have done the classic set up on Netlify side for custom domain add, which to replace the namervers in with the ones provided by Netlify. I have checked with themselves to verify that my website in pointing to those 4 namervers and they told me that they do, by running the command Whois.

It has been days now and so I am not sure what else to do than to ask you for help.

The website was accessible for a brief period of time a day ago, then went back into not accessible shwoing now the error message DNS_PROBE_FINISHED_NXDOMAIN when tryin to access it.

I tried to add an A record looking at the support forum, I have now deleted it thinking it might help fix the issue.

I am now unsure of the direction to head towards? what is the issue?

Appreciate any help on this,

Thank you!

You haven’t done so correctly.

No Netlify name servers:

$ dig NS		4502	IN	NS		4502	IN	NS

whois tells a different story

$ whois

# [output omitted]


nserver............: [OK]
nserver............: [OK]
nserver............: [Technical check not done]

You need to remove the and servers and replace them with the 4 servers provided by Netlify. You may also wish to double-check you’re follow the correct procedure. Read: Domain Management: How To Update Nameservers. It can also take 24–48 hours for propagation to complete (as noted in that article). Read: What is Domain Propagation.

1 Like


I did change those nameservers in, 4 days ago. Dig and whois dont return the nameserver values I have set in

to continue on this story it has been 4 days since nameservers change and the propagation is still not complete as shown here: DNS Checker - DNS Check Propagation Tool

I am checking with to ask them to verify the DNS configuration, as I have seen online that someone stayed 1 month like this and it was a DNSSEC configuration error

So far it doesnt seem like a Netlify error

note: the first time I changed nameservers to netlify ones for the beta test of the website it worked after few hours propagation. The second time I changed the namervers for the production versoin of the website, it didnt work after 48 hours, so I re did the domain assignment process on netlify that gave me another set of nameservers to set up and so here I am 4 days later without a website

Seems like previous namservers configuration is still set up somewhere

News, is telling me to see with the nameservers provider to see if the DNS zone files are correctly configured

Whom am I supposed to ask this ? :smiley:


As far as I am concerned, this is an issue with the configuration you have at domain܂com (the their service entirely) and not Netlify.

Well says its Netlify, and Netlify says it’s

I have set an A record pointing to as said in the “set external DNS” doc

sometimes it works, sometimes it tells me that there is a privacy issue with the website

Serious nightmare this thing :joy:

Netlify didn’t say it, I said it (and I don’t work for Netlify.)

I don’t see this.

$ dig		4502	IN	A
$ dig	4502	IN	A

Where have you set the record?

Using external DNS configuration is probably a good option for you in this situation. You don’t change name servers (you would need to remove the Netlify name servers and remove the domain from Netlify DNS) you set an A record for the apex domain, a CNAME record for the www subdomain at your registrar and assign your domain to your site in Netlify.