Unable to link to a different repository

My site name: condescending-brattain-195a80.netlify.app

Hey Netlify folks,

I’m finding myself unable to link my app to a different GitHub repo. I recently converted the repo I was linked with on GitHub from a personal repo to one owned by an organization, so I attempted to update my configs here. I ran into the following issue:

  1. Went to settings
  2. Selected Build & deploy
  3. Under Continuous Deployment, I clicked on Edit settings under the Build settings panel
  4. Clicked on Link to a different repository which takes me to https://app.netlify.com/sites/condescending-brattain-195a80/link
  5. Click on the GitHub button on the page
  6. I’m taken to a screen with the Netlify logo that says “Authorized” - there doesn’t appear to be anything to click on from that page and, when navigating back, I can’t proceed beyond the Connect to git provider step

Any help? I also tried creating a New site from git from my sites page and it looks like it encounters the same issue when trying to connect to GitHub - so might be a universal issue with my accessing GitHub (though the first time I authenticated things worked perfectly).

Any help would be greatly appreciated! And let me know if you need any other info from me.


Hmm, that is usually caused by a misbehaving browser plugin/extension. Could you let us know which browser and version you use (we recommend one of the big 4, a recent release: of firefox/chrome/edge or safari, and also confirm that this happens with all plugins/extensions disabled?