Suddenly I cannot add a new site from GitHub


I’m facing the connection issue between Netlify and GitHub repo.

Last week I could see selected repository as an accessible choice.
However, right now I cannot see it and cannot select All repositories like the below. I haven’t changed any settings on both sides(Netlify and GitHub).

Has anyone faced this issue before?

Additional info

This issue seems to have started in the evening. (12/1)

Thank you in advance!


I am having the exact same problem today. I’ve deployed two small apps previously just fine, but I tried to add a third today with this issue being encountered.

Could you tell me when you did try to deploy the third app?
If you told me that, I would be able to add extra info which might be helpful to get someone’s help.


Just prior to my post this evening

Same issue here as well, my Netlify app settings look the same is on the op’s screenshot. The only option is “All repositories”, but even that is not selectable.

Also, just checked a separate github account I have for work, and looks like the same behavior there.


Thanks! I will this info to my post.

Also seeing the same behavior as everyone else in this thread as of about 10 minutes ago (9:25pm PST)


Same here, cant change any settings via github

1 Like

Same for me as well!

1 Like

Same stuff happening to me!

1 Like

Just bumping the topic. Same for me as well…

1 Like

Same for me as well!

Is this the right forum for this issue?
It seems to be quite a critical issue, is it being handled?

Same here. I’ve had no issues before today. I have two Github organizations and before today I was able to connect anything. Today I am seeing the same as the screenshot above on both orgs.

hi to everyone in this thread! thanks for making note of this. Is everyone who reported this issue still having problems? can you give me more specific information about sites, times, anything you have tried please so we can investigate?

1 Like

The issues seems to be fixed now. :slightly_smiling_face:


Just to add to what @perry said, next steps for those still have issues would be to:

  • uninstall the github app
  • then re-link their repo to get that app re-installed in github

and see if that helps! please let us know if it does or does not fix the problem!

1 Like

Thanks for the update. Let’s see if the others see the issue resolved as well. :crossed_fingers:


fixed for me! Thanks @perry!

1 Like

Looks like this is now also fixed for me in both my personal and work accounts. Thanks!

1 Like