No longer able to link with GitHub repositories

Hi there

I’ve previously been able to import my projects from GitHub repositories. However, for my latest project, I’m getting the following error message:

No repositories found

This can happen when Netlify doesn’t have access to the repositories in an account.
Configure the Netlify app on GitHub, and give it access to the repository you want to link.

I’ve tried disconnecting then reconnecting my GitHub account under “Connected accounts” in User settings but I still get the same error message.

Any ideas what is going wrong please?

Thanks

Hey there. @thunderfingers :wave:

Thanks for reaching out. Can you share your Netlify Team Name, as well as the method you are using to connect your GitHub repositories? This will help us look into what you are encountering further.

Hi! My Team Name is Thunderfingers. My Netlify settings show my GitHub account is connected to my Netlify account. I’ve been trying to connect a new repository by going to Add new site > Import an existing project, then clicking on “GitHub”.

I’m not sure if I’ve answered your question properly, please do ask if I can clarify anything!

Thanks.

Any thoughts? Thanks in advance :slight_smile:

Could you try to uninstall Netlify app from your GitHub settings before re-linking Netlify with your GitHub account?

Thanks @hrishikesh. Would you happen to know where to find the Netlify app in the GitHub settings? I’ve been trying to work it out but can’t find it in there. I have tried unlinking and relinking GitHub in my Netlify settings but that didn’t work.

Hi @thunderfingers ,

I believe what you are looking for is:

  1. Select your user account/profile/avatar in the upper right-hand corner of your GitHub screen.
  2. Select Settings.
  3. Under the Integrations section, select Applications.

I hope that helps!

1 Like

Hello @elden
Please I have the same issue but I use BitBucket.
Please I need your help.

Did you try what was already suggested above @tractionapps?

Thanks for the reply.
I can’t seem to figure out how to uninstall Netlify from BitBucket.

@hrishikesh
Please did you get my reply?

Hi @tractionapps,

Could you go here and revoke access and let us know if that works for you?

Hello @Melvin
Thanks for the reply.

I revoked both Netlify App OAuth and Netlify.
Then tried authorization again but I still got the same result.

Also “Netlify build. deploy & host…” didn’t come back.

Thanks. Really anticipate your response.

Please this revoke action I did is preventing us from making updates to the current hosted sites.

Hello guy.
I was able to figure out what the issue was.
Apparently, there was a different email that was used to create all the repos while we accessed from netlify using a totally different email.

But thanks for all the support.