Unable to create a new site from GitLab repo


I’m unable to deploy any new website from GitLab. I can connect to GitLab, I can select a repository from the list of repositories, but then it fails to actually deploy.

Looking at the Network tab it shows that it successfully starts to retrieve repository files from the selected repo, starting with the file tree, the netlify.toml file and package.json file. But then it fails with the functions file / folder, returning a 404.

This happens to me with 2 different Netlify accounts, 2 different GitLab accounts, with new repositories and repositories that haven’t changed for nearly 2 years, and in 2 different browsers. It consistently keeps showing the same error.

The ability to deploy existing websites doesn’t seem to be affected. Hopefully either you or GitLab can sort this out soon. I have a workaround for now by reconfiguring the development website to turn it into production, but this obviously is a bit of a problem.


@woutervandam I wonder if this is related to this issue?

Hi, @woutervandam. Would you please send us a link to the failing deploy?

The problem is that I’m unable to create a new website, so there is no link.

I’m still getting this error, so it doesn’t appear to be a temporary glitch. And I’m trying to create new websites from repositories that I’ve previously deployed to Netlify with success. Most of those are still running and those that are can be redeployed without a problem. The problem is specifically with creating new websites.

I’d suspect access issues or something related, but it shows the list of repo’s just fine when I select Gitlab, and it also succeeds in getting the file tree and two files from the repo. It specifically fails at getting the functions folder. Which does exist in the repo, and is listed in the repo file tree.

Hi, @woutervandam. Sorry for asking for a deploy link when the issue was not being able to link repos at all.

This issue has been escalated to our developers and they are working on the issue. We will post an update here when it is known to be resolved.

If there are questions or other information to share in the meantime, please reply here anytime.

1 Like

These problems occurred not long after getting access to the Netlify and Gitlab accounts of my customer. It might be related. Still, everything seems to go fine, until it gets to the functions folder.

We are experiencing the exact same issue. We had a functional site and we are wanting to make a staging version of it on another repo but we cannot link it through gitlab. I was able to get to step 3 when I had an empty repo with just a readme but when I replaced it with the netlify app files it errors with:

“We couldn’t access the repository reposity/name. This could be because the repository is empty or disabled.”

We may have found a work around.

Create a new repo in gitlab that just has a readme.

Create the site in netlify.

Push code to the gitlab master branch

This seemed to work for use to get around the error when trying to read the gitlab repo with the code files in the repo.

1 Like

Hi @deplume and @woutervandam,
We finally got to the root of this complicated bug and have shipped a fix :tada: Could you please try creating a site with the repo you want and let us know if this is working better for you now?


Thanks! I just tried deploying a new website from a repository that wouldn’t work before and it’s working fine again.


fantastic! glad to hear that.