Home
Support Forums

Link to git(lab) repo fails, new site deploy from git also fails

When I try to link an existing site to a Gitlab repo it just throws a generic error:

"Looks like something went wrong!
We track these errors automatically, but if the problem persists feel free to contact us."

I also tried creating a new site directly from git. Same error.

Help?

EDIT: I’ve ready this thread. I want to do it via the Tor browser. It connects to Gitlab, I can see the repo, enter build commands, click on Deploy and got that error.

Hey there, @garlicseas :wave:

Welcome to the Netlify Forums, glad you found us! Can you share which site you are trying to link?

1 Like

Thanks for your fast reply! @hillary

Sure. Here is the Gitlab repo: Gabe Seaman / monero-wormhole · GitLab – it’s a Jekyll site.

I have both tried: a) creating a new site > from git and b) also linking the repo to an existing Netlify site I have created manually which is not building from git.

I would also like to add that I can see Netlify as an Authorized Application in my Gitlab, so it has permissions with the scope read_user. Also tried revoking/re-adding it, same result.

Hi, @garlicseas. We would need more details about the linking failing to troubleshoot. I would normally ask if you could make a HAR file recording of the issue occurring and I believe the Tor browser supports this as well. Would you be willing to make such a recording?

(If so, please do not post it publicly as it will probably include you access tokens. Please let us know you if made one and we will create a support ticket to exchange it.)

Also, are you using Bitdefender by any chance? If so, we are getting some reports that the web UI doesn’t work until you make a website exception for our site in Bitdefender. (Not everyone is affected though. I use Bitdefender and have no issues.)