Can't see a list of my GitLab repos to connect netlify to

Hi,

I’m trying to connect to a repo in my GitLab account, but getting stuck somehow.
Here’s what’s happening:

  • In Netlify, I go to ‘create a new site’ (here in effect: https://app.netlify.com/start ), and choose ‘GitLab’ under ‘continuous deployment’ heading. It opens up a new window, and shows ‘Authorised’
  • I look at GitLab, and go to ‘settings’, and then ‘applications’, I can see that Netlify is an authorized application.

No GitLab repos showed at this stage, so I also then revoked the application on GitLab, and tried again from the ‘create new site’, and click on the ‘allow’ button at the permissions screen, and then I see ‘authorized’ again, and still no repos show.

It’s not working because I can’t move forward to the ‘pick a repository’ section of the start page.

Any suggestions, please?

Many thanks,

James

I realised that I was perhaps missing a webhook in gitlab, and so I’ve added that, but unfortunately this issue still continues.

I have exactly the same issue with connecting to my gitlab account.
Any help would be appreciated! :slight_smile:

Thanks in advance!

I click on the ‘create a new site’ (here; https://app.netlify.com/start ), and then I select GitHub, and it shows as being authenticated. Yet I can never get to connect it to a specific repo. Exact same happens with gitlab. I can see netlify as an ‘authorised github app’, and also the same in github.

I’ve read this page: https://www.netlify.com/docs/github-permissions/ but the screenshots, and info don’t really match up with anything that I see either within netlify or gitlab!

I’ve tried so much to try to get this working so far! Any thoughts on what I need to do would be gratefully received, please? :slight_smile:

I posted a similar question elsewhere in the forum, but have not had a response since yesterday; I’m sure it’s something simple that I’ve not done!

The usual reason for not seeing a repo on GitLab (or Bitbucket) in our repo linking UI is that you are not an administrator on that repo. Can you confirm that you are either an owner or an administrator (can create webhooks) at GitLab on the missing repo(s)?

GitHub is quite different since it uses the app entirely. While you’ve authorized the GitHub app probably for your own repos, do you also own the repo(s) you don’t see, or might they belong to an org as well?

It seems to be browser-based. I had the exact same experience in Firefox and tried in Safari (thinking it might be NoScript).

Just to clarify for fool…

  1. “New Site from Git”.
  2. Select your provider.
  3. Second window with Gitlab authorization screen pops up. Authorize.
  4. Second window updates to Netlify “Authorized” view.
  5. … and nothing else happens.

You never get to the point of selecting a repo. It’s not that there’s a list of repositories and the desired one is missing, but you never complete the authorization process. After authorizing with the provider in the second window, the first never updates.

Hi, @lukehler. The “New Site from Git” button works for me when I test in Firefox. I created a support ticket to troubleshoot and we’ll follow-up here once the solution is know.

Also, please reply here if you don’t see an email about the new support ticket.

Rather than Firefox itself, it’s most likely NoScript in my case. And that’s not in any way unexpected but it would be nice to have a documented workaround.

When I get a chance to do so, I’ll try it with NoScript disabled and see if I can verify that.

1 Like

great - let us know what you find.

@lukehler, I’m also a fan of NoScript. Here are the exceptions for Netlify I’m currently using:

noscript-exceptions

This has been working well for me.

If you find more restrictive settings which work better for you (as - as least in my opinion - more restrictive tends to be better with NoScript), we thank you in advance if you would be willing to share those here. No pressure - just letting you know additional input is welcome.

Turns out we had the same settings for NoScript and it works as expected in Firefox but not in Firefox Developer Edition, even with NoScript set to disable restrictions globally (or with the plugin completely disabled). The plot thickens.

Haven’t isolated it any better than that, I’m afraid. I’m guessing there’s a difference in the settings that I haven’t spotted. The only small request would be to consider menubar=true to aid in troubleshooting in case of an issue.

Again, works fine with standard settings. So a small annoyance worth noting if others run across it.

1 Like

thanks for clarifying that @lukehler!

Just a random thought: does anyone have privacy.firstpaty.isolate enabled (don’t want to test turning it off, with hundreds of tabs)?

I have the same problem, when free users were able to contact via email, I did with this issue.
Disabling FF Enchanced Tracking Protection, uBlock, Privacy Badger doesn’t help. Debugging via other means also didn’t have any result.
Only thing what worked is creating a fresh profile. But when I needed to move to a fresh profile (stuff got semi-corrupted due to multiple power loss incidents. It seems that the new profile got ‘tainted’ with anti-netlify and the same thing is back.

Right now I added 20 sites, so I can change the repo when I need one ‘new’.

Also an another note, I couldn’t sign in to answers.netlify.com with netlify oauth, clicking the oauth button brings me to netlify, but then after pressing ‘authorize’, it brings me back, without logging in.

Thanks again for the debugging and sorry to hear about the OAuth issue. I’ve asked a colleague to ensure that this works or remove that option for now if not!

Btw if you want, my support case id was 8344.