Unable to create a site based off gitlab or relink to gitlab

When I go to “Create new site from git”

And click gitlab I am greeted with this error

You must specify a provider when calling netlify.authenticate

Unsure how to proceed.

this happens regardless of the computer or incognito window.


I’m having the same exact error with bitbucket

Same issue for me.

Seeing the same with gitlab. Unable to create a new site, with the same error.

Same Issue. Tried on different browsers and logging in with different gitlab users

Deploying a site from Github is working though.

Same error for me for Gitlab and Bitbucket. There is another post with a number of others reporting the same issue. Must be a bug, hopefully resolved soon.

Hey there, thanks for your report! We clocked an issue which was preventing customers from linking to repos on GitLab and Bitbucket.

We’ve remediated the problem and updated our Statuspage to reflect the issue. Again, thanks for bringing this to our attention!

1 Like