Home
Support Forums

"Transaction denied" when trying to upgrade from Starter to Pro plan

Hi, I just wanted to upgrade my starter plan to Pro for 19$/month, but when I want to finalize the transaction with the correct payment details, it just shows a red “Transaction denied” message. What does that mean, can somebody help? Would really appreciate it!

Hiya!

I’ve only ever seen this error show up if the card information you’re inputting is inaccurate (i.e. expired, wrong credentials). Can you double check it for me?

If it’s still an issue, would you mind sharing the output of your browser’s dev tools window, please? I’m assuming that it’ll throw an error which we can use to help home in on the issue :slight_smile: Ooh, and could you confirm the team name? :smiley:

Hello Pie, thanks for your kind reply.
The credit card information should be correct as it is the same card info that is used monthly to book additional bandwidth allowance, which happens mostly every month :slight_smile:

Here is the error:


Hope this is helpful information.

Team name is cosee-website.

Hey again :slight_smile:

How peculiar! Does it work in an incognito window, without any browser extensions enabled? Sometimes ad-blocking-type browser plugins can inhibit our communication with our authentication service and using an incognito can get around this.

Please let me know how that goes!

Hi Pie, thanks for your suggestions. I tried two different browsers with incognito and private mode (Firefox and Chrome), both unfortunately didn’t work, “Transaction declined” appeared again…

I also re-entered my credit card details and this didn’t work as well… But they are used monthly to book additional allowance, so they can’t be wrong. :frowning:

hey millymilly, i am moving this to the billing helpdesk where you can chat with us about this and we can get you upgraded! Expect an email from us.

1 Like

Hey @millymilly , not sure if anyone talked to you in the helpdesk about this already, but we were able to figure out what was going on with your account and we think we have cleared up the problem!

Can you try upgrading again and see if this charge goes through? thank you for your patience as we worked through this.

It worked today, thanks a lot! I am Pro now. :slight_smile:

Thanks for your help and quick fixes.

1 Like

@Pie We are having this exact same issue as @millymilly: error 422 - payment info was accepted but transaction declined. Any chance you could message me on how to fix it? Thanks

Any chance you can share the specific error from your dev tools window and/or our UI? This’ll help us to pinpoint the issue. There’s several reasons why a 422 may arise. Thanks!

Happy to share. Can you message me directly?

Here is the error received.

Hey there!

Can you confirm the site and team that you’re looking to upgrade, please? Is it the same team that is associated with your Forums email address?

Furthermore, can you confirm that you have attempted to upgrade in a different browser, without plugins/extensions and/or in incognito mode? Can you attempt to successfully deploy a site, too, if the query relates to the team that has not yet deployed a site?

Yes it is the same. I’ve tried again with new browser window, no extensions, incognito and all still have the same result, same error.

Hi @Pie ,

May I know how could this be fixed too? , I’m also getting the same error 422 when I’m upgrading mine to Pro.

Thanks

I’m having a error while trying to register a new domain and it’s just says the error “transaction declined” can anyone help please??

hi there @zekajrinor1 - i have moved this conversation to our billing helpdesk so you can talk to a billing specialist - expect an email from us!