[SOLVED] Previews and branch deploys not working (can't reach netlify.app)

Previews and branch deploys not working. Pinging the URLs (*.netlify.app) returns:

cannot resolve [URL]: Unknown host

Tried a global ping tool and noticed that is failing from some locations.

Hi, @butaca. We’ll need to know where the DNS lookup is failing. Ideally, we need a traced recursive lookup at the affected location. I use dig for this level of diagnostic information. Here is an example:

$ dig example.netlify.app +trace

; <<>> DiG 9.10.6 <<>> example.netlify.app +trace
;; global options: +cmd
.			86764	IN	NS	a.root-servers.net.
.			86764	IN	NS	b.root-servers.net.
.			86764	IN	NS	c.root-servers.net.
.			86764	IN	NS	d.root-servers.net.
.			86764	IN	NS	e.root-servers.net.
.			86764	IN	NS	f.root-servers.net.
.			86764	IN	NS	g.root-servers.net.
.			86764	IN	NS	h.root-servers.net.
.			86764	IN	NS	i.root-servers.net.
.			86764	IN	NS	j.root-servers.net.
.			86764	IN	NS	k.root-servers.net.
.			86764	IN	NS	l.root-servers.net.
.			86764	IN	NS	m.root-servers.net.
.			86764	IN	RRSIG	NS 8 0 518400 20200513050000 20200430040000 48903 . BnY3EmRQ9/ZtQJlV2gdQ22niomltyh1WYdwe/KksDt0E+6UJTWnJX1LX RZySnHMU46SIR4MdNf02JKOkxjtqXqdp5O9yZiqGmS3m2AYSsDu/UYGy As51PS5iJ3DCVfD8iyxk32laxpjxeAcu9gvvtxIo3nozK1G/gz3whiL2 TCmrM3d99opR9lSq4rXHROFErcLJzQwcf3jOEvJIPitPXdd5DGpfT5hf idtaz4j/KhA0+9S/SGvRhpJTrwTYvs6q65+JBnLQ3nH2JKO2z3hVAuAf tdbeSEU+jQha4/c+fpFiHtFu7ASt6PzcM/vQFFH/ZnXJIiYyqz/3ybAe 5agbag==
;; Received 525 bytes from in 24 ms

app.			172800	IN	NS	ns-tld4.charlestonroadregistry.com.
app.			172800	IN	NS	ns-tld3.charlestonroadregistry.com.
app.			172800	IN	NS	ns-tld1.charlestonroadregistry.com.
app.			172800	IN	NS	ns-tld2.charlestonroadregistry.com.
app.			172800	IN	NS	ns-tld5.charlestonroadregistry.com.
app.			86400	IN	DS	23684 8 2 3A5CC8A31E02C94ABA6461912FABB7E9F5E34957BB6114A55A864D96 AEC31836
app.			86400	IN	RRSIG	DS 8 1 86400 20200513170000 20200430160000 48903 . aU7kpIvfTgUP532yBCYUAUeSzpW6a4WLldDhkuEZhocPUoS3UtlBHszv xPF9tjvBaSKossa2NtlNA0ki+wySKCS3/Jx95buMI6cjdYlbrRYB9COD cqQc4Abb7DYp9FPdFe+Sv92VnVXS3rU0Y4TylxlsjIJV1RWlTqPgqbgr Yv58pUjwOXKYb81hL9QrXUnsSFmN8WCC10FgpOToRihB6Aa3zvipw19n jKVD/PzQC5mq0cc7F3Hlh4u2QyBmvZ9IJvJM6UgCj5QjGam1W6sz1xiW w+gm8cxfgL0hJc3zNIUjCkrfur9PjqvH2awVxkh3qxjOVhu9LL+GAb0K L7rV+w==
;; Received 739 bytes from in 103 ms

netlify.app.		10800	IN	NS	dns1.p01.nsone.net.
netlify.app.		10800	IN	NS	dns2.p01.nsone.net.
netlify.app.		10800	IN	NS	dns3.p01.nsone.net.
netlify.app.		10800	IN	NS	dns4.p01.nsone.net.
haqa3ebohni63ah1pgrs4ojlotehoudk.app. 900 IN NSEC3 1 0 1 139FCA6C02909936 HAQAIBO79DV4H7DRSACVPUH32PUHK8NI  NS
haqa3ebohni63ah1pgrs4ojlotehoudk.app. 900 IN RRSIG NSEC3 8 2 900 20200521094155 20200429094155 21013 app. icjrj+wL4hpXQ54lKZvB0nqwoFjJ36ujvUdYs/kmjfcXLzvG1/Te26DG V6mExUklnPh92KdPixX+Lot4ifsBeU0jvdrhRBaoumF9MIri/vVShh1/ SiOBQIdfgo+2PJ5WBuLS2Vr2tda/dDsvFhCWzzJlclM8uKCKlkPTKwdn 8aM=
;; Received 382 bytes from in 77 ms

example.netlify.app.	20	IN	A
;; Received 64 bytes from in 19 ms

It would also help to know what domain name is being queried and what DNS resolver is being used. For example, in the DNS lookup above that information is:

  • DNS resolver =
  • domain name = example.netlify.app.

Would you be willing to please send us that information for a location where the lookup is failing? This is the information I am hoping for:

  • DNS resolver used
  • domain name queried
  • the traced recursive lookup (dig NAME_HERE +trace or equivalent)

Thanks for your response.

DNS resolver =
domain name = netlify.app

dig netlify.app +trace
; <<>> DiG 9.10.6 <<>> netlify.app +trace
;; global options: +cmd
;; connection timed out; no servers could be reached

I have a site that is using Cloudflare DNS and is working properly, all the other sites that are using the Netlify DNS aren’t working.

EDIT: moved another site to Cloudflare DNS and is also working. I cannot reach the sites under Netlify DNS.

EDIT 2: sites under Netlify DNS are up now.

Thanks for sending that information, @butaca.

Looking at the dig +trace output, I see that even the root server lookup is failing. This is the lookup normally returns a.root-servers.net. through m.root-servers.net.. Those records have nothing to do with Netlify and still were not found.

This doesn’t indicate that Netlify DNS wasn’t working. This shows there is a complete failure of the DNS resolver. This is the DNS resolver ( itself is not working.

This system (the one using the IP address isn’t a Netlify controlled system. Failures of this DNS resolver are not something we can control.

To summarize, all data so far indicates that Netlify DNS was working correctly. The data shows the DNS resolver itself was the root cause of the failure.

If there are other questions, please let us know.