Branch Deploy reports not found


so just started to use branch deployment, and it appeared to have worked until we tried to navigate to the branch url.

So the branch url is
you get a 404 when you go to navigate to it.

However if click preview in netlify dashboard, it loads fine, the url is

Both links are from the netlify dashboard.

Is this dns related? Or have we done something wrong? We are using netlify dns. I am assuming custom url will work once this works.

Hey @sham480,

First thing’s first – is there a Git branch called ‘feature-netlify-cms’?

Hi @Pie,

the branch is actually feature/netlify-cms, it substituted with - i assume as to make it a valid url.

Oooh, from memory, I can’t recall how slashes are handled! Interested to know if changing the branch to feature-netlify-cms did in fact help though!

thanks, i will check if that works, i deleted the branch, but can create a new one with slashes instead and see what happens

so looks like branch with names with slashes works fine. You cant use / even though it converts it to - in the url.

@Pie however i could not access my custom url using the new branch. Is there something extra i need to do?

If you have a custom domain, in order to make use of branch deploys (and branch subdomains), you’ll need to ensure that you’re using Netlify DNS.

Alternatively, if you don’t mind having your branch on a separate site, you can do just that – add the separate branch as a second site within your team!