Git branch not available to deploy

  • Netlify site:
  • DNS custom domain:
  • Problem: My dev branch isn’t available on Netlify. I can’t select it as a sub-domain or run a build from it. I have two branches, main and dev. Is there something I am missing? Deploy previews work when I create a pull request from dev into main.

Welcome to the forums @taz

Under *Site Settings > Build & Deploy > Continuous Deployment > Branches do you have either All or Let me add individual branches selected e.g.

Hey @coelmay

Thanks for the quick response.
Unfortunately it is still not appearing - please see screenshot below.

Yes, you can select All if you wish and not explicitly specify a branch name (if you have other branches, or may have other branches in the future, that you don’t want built, then specifying branches to build can come in handy.)

If All or the specified branch was not selected prior to pushing the branch to origin, you will need to commit to the branch again to have Netlify pick it up.

1 Like

Unfortunately, still having no success even after making the settings change and doing a commit:

Hey @taz

Could you try to relink the repo from the UI?

1 Like

That worked! Thank you :slight_smile: