Branch Deploys not working; branch subdomains showing old linked repo branches

Hey there,

This is my first project using Netlify; apologies in advance for any redundancy. I did comb the forums and haven’t found any topics addressing my specific issue.

I’m working on site Using Netlify’s Next.js integration, basically all default settings. All’s been well working on the main branch, but when I try to enable branch deploys to follow a test branch in my linked repo…nothing happens. I’ve tried committing from the repo, triggering a deploy in the Netlify app, etc. but Netlify doesn’t seem to be aware of the other branch. Build logs don’t mention the test branch at all.

Perhaps tellingly, when I try to add a branch subdomain, the only options in the dropdown are branch names from the repo this project used to be linked to (we switched to a new repo due to an upgrade in the codebase around the time I came on the project). This makes me wonder if the issue is somehow related to having switched to a new repo – maybe some vestigial crossed wires?

Anyhow, I’m stumped. Any advice/redirection very much appreciated!

Take care,

Still fighting this. Short of scrapping and rebuilding the whole Netlify site, I’m not sure how to proceed.

Has anyone else had trouble getting branch deploys to trigger after switching linked repos?


Hey @gammaSpace,

I can see branch deploys for test branch on your site: Netlify App. Are you still having issues, or did you manage to fix it?

Hey there,

I was able to get the problem resolved, but only by creating a new netlify site and linking it to the same git repo. For some reason this also forced a refresh of the original site and caused the branches I needed to access to reappear. No clear explanation why this was the case, but it works now!