Home
Support Forums

Site not deploying automatically on push

I recently started having this issue where any new changes I push from GitHub doesn’t get deployed automatically. When I encounter this issue, I usually Trigger the deploy manually before i can see the changes.

Please how can I make this automatic again.

Things to note:

  • I don’t have a build command
  • No base directory set
  • No publish directory

Here is the deploy log

3:44:20 AM: Build ready to start
3:44:22 AM: build-image version: 2cee85eb7f808bf3b6e87378c5307f9411f0a332
3:44:22 AM: build-image tag: v3.8.0
3:44:22 AM: buildbot version: 7ed3dd8fac64067d9cac4a8ffcf331d1669e61a3
3:44:22 AM: Building without cache
3:44:22 AM: Starting to prepare the repo for build
3:44:22 AM: No cached dependencies found. Cloning fresh repo
3:44:22 AM: git clone https://github.com/Evavic44/Victor
3:44:23 AM: Preparing Git Reference refs/heads/main
3:44:23 AM: Parsing package.json dependencies
3:44:24 AM: No build steps found, continuing to publishing
3:44:24 AM: Starting to deploy site from ''
3:44:24 AM: Creating deploy tree 
3:44:24 AM: Creating deploy upload records
3:44:24 AM: 4 new files to upload
3:44:24 AM: 0 new functions to upload
3:44:24 AM: Starting post processing
3:44:24 AM: Post processing - HTML
3:44:24 AM: Processing form - form 1
3:44:25 AM: Detected form fields:
3:44:25 AM: Finished processing build request in 2.992022119s
3:44:25 AM:  - Message
3:44:25 AM: Post processing - header rules
3:44:25 AM: Post processing - redirect rules
3:44:25 AM: Post processing done
3:44:25 AM: Site is live ✨

Hi @Evavic44

Welcome to the Netlify community

Have you possibly locked a deploy like the image below? (You would see this on https://app.netlify.com/sites/victoreke/deploys)

If so, you will see a Start auto publishing button. Selecting that will start auto-publishing your site again.

If not, another option is you might have Stop builds selected

If so, change this back to Activate builds (even if you don’t have a build command.)

Let us know how you get on.

Thank you @coelmay for your respsonse. I checked, and I don’t have any deploy locked and auto publishing is active.

I temporarily pushed a slight change to test it out and it still didn’t deploy automatically.

Hey there, @Evavic44 I know this may seem obvious but can you check that your deploy settings are configured correctly.
You can access them here

Here’s what your settings should look like:

It would also be useful if you posted a screen shot of your deploy settings so we could check for issues there.
Here’s what that looks like

1 Like

Deploy context

The only difference I’ve noticed is the Branch Deploys settings, don’t know if that is the cause of the issue. If I must add, I’m experiencing this in all my hosted repos, which is kinda strange.

1 Like

Build Settings

1 Like

You mention that this issue is happening in all your hosted repos with Netlify… thats a big :triangular_flag_on_post: for me.

This might be down to something with Netlify & GitHub integration. I would go over all your Github settings that mention third party access and the Netlify integration app.

If you don’t find an issue there, I’ll be happy to escalate this for you where a support engineer will be able to determine if this is an issue on the Netlify side.

1 Like

Right!!! I wanted to mention something about that (The third party apps), will go through it now. Thanks for the feedback.

2 Likes

Hi @Evavic44,

Could you mention what exactly has not updated? For example, I checked your GitHub repo’s commit history and I found this:

Which seems to be in sync with your website:

image

image

Oh yes, I triggered the deploy manually that is why the changes are in sync. Let me do a test change for clarity of the issue.

I just made a slight change 19 mins ago to my repo for testing and it isn’t on sync.

Here is a screenshot of the change I made.

live-value

Here is a screenshot of my repo commit.

repo-chnages

As you can see, the commit is available on the repo but not on the website.
This is where I have trouble buidling my recent pushed commit. Unless I manually trigger the build.

Oh yeah, I see it now. I’ll investigate this further and let you know.

1 Like

Looks like the last build that worked from GitHub was on June 24. I can see that there are no commit messages for any of the newer builds. That might mean that you’ve deployed all of them manually.

Just like @kylesloper said above, there’s a chance that your GitHub <-> Netlify integration might be broken. Would you reconfigure it and let us know how it goes? You might have to remove the Netlify app from your GitHub account and re-add it.

2 Likes

Sorry, please how can I do that? I’m I supposed to delete the website from the Netlify platform and re add it?

can you try logging into github and revoking authorization for us first, and then re-authorizing us? that might help reset things.

2 Likes

I’ve done that, still didn’t work. :cry: What I did was

  • Disconnect my GitHub account from netlify.
  • Removed the netlify GitHub app and added it again.
  • Revoked the authorised netlify Oauth app from GitHub

how strange. can you post a screenshot of your current build settings please?

1 Like

Hey @perry, I see @Evavic44 has already posted their deploy settings:

1 Like

Thank you @kylesloper