Page not found on a specific page

I have recently deployed a fullstack vue project and most of the pages behave propely apart from one page that has a page not found. All pages are written in the exact same way and routes are manages by Vue routes. All pages like home page, create blog page and read a blog page all work apart from your profile page. Even though that are all written and managed the same way. Does anyone have any pointers on why it isnt working? the full website is here:

Hi, @Kroplewski-M. To troubleshoot we need to know the page which is not working. The URL you have shared is returning a 200 response:

$ curl --compressed -svo /dev/null  2>&1 | egrep '^< '
< HTTP/2 200
< age: 1
< cache-control: public, max-age=0, must-revalidate
< content-encoding: gzip
< content-type: text/html; charset=UTF-8
< date: Thu, 24 Nov 2022 05:34:26 GMT
< etag: "8bc426d0dbbc7e3fd35d57c4f6955111-ssl-df"
< server: Netlify
< strict-transport-security: max-age=31536000; includeSubDomains; preload
< vary: Accept-Encoding
< x-nf-request-id: 01GJM22KMYJD3YZN84YGPPRZKF
< content-length: 1990

What URL returns the page not found?

Hi, @luke
Its the /profile page. You have to be logged in to access this page. Ive created a test account for you:
Password: test123

Hi can you share a repo for this site?

this is the repo: .
Thanks for looking over much appreciated.

Hi @Kroplewski-M I can’t see a _redirects file in your repo. Have you had a look at this post?

Hi, @kylesloper thanks for the reply, i added it in and still get the issue. I dont know if im doing it wrong but i did exactly what the answer said with no effect

Hi @Kroplewski-M,

Thanks for the follow-up.

It seems that the redirect file isn’t being processed. You can see this in the deploy log under deploy summary. Does this solution work for you for placing your _redirect file?

Hi @Melvin , how would I place it in the static directory. I think I’m being dumb here but I don’t know what it means by that

Vite uses public as a directory for static, unchanging files. Create a public directory and move your _redirects to it :slightly_smiling_face:

Hi @Kroplewski-M,

As @kylesloper correctly mentions, you can create a public directory at the toot and add the _redirect file to that. Another option would be to create a netlify.toml file to the root and add:

from = "/*"
to = "/index.html"
status = 200
force = false

Let us know if you continue to have issues. Thanks!

Ayy, i added the netlify.toml file and it worked. Thanks!

Hi @Kroplewski-M :wave:t6:! Thank you for coming back and letting us know this worked for you! We appreciate the feedback dearly. :netliconfetti: :smiling_face_with_three_hearts:

1 Like