Netlify subdomain: Server Not Found?

Hello all, I have tried setting up a seperate repo and site on a subdomain for my domain I registered through netlify: lmmapping . com.
I have tried adding the subdomain: experiments . lmmapping . com
I keep intermittently getting a server not found error when trying to navigate to the site. In the netlify dns settings I have specified the CNAME address for this subdomain so I have no idea why it works sometimes but not often. This is the netlify url if anyone can help me!
I have checked the dns propagation through: and it shows it propagated ! any help greatly appreciated!!

Hi, @lm93547. Welcome to our online community! :+1:

I’m not able to reproduce this now. The URL always works for me when I test.

Is this still happening for you?

If it stopped happening, my best guess about why it happened is that sometimes the DNS lookups were going to your old name servers. At those servers this subdomain had not been configured (because it was only configured in the Netlify Managed DNS).

If this is what happened, it was probably because the old NS (name server) records were still in effect due to time to live (TTL) values in the records themselves:

So, sometimes the DNS query would go to Netlify and sometimes it would go to the previous DNS service which didn’t know about the subdomain and it would return the “server not found”.

I only show Netlify DNS being used now so it shouldn’t happen anymore.

If it is still happening, please let us know and we’ll be happy to take another look.