Netlify Password Reset and Invitation Password modal not working

Site - extraordinary-sunburst-d853b2

I’m using the netlify identity widget and everything is working as it should EXCEPT for the password reset and invitation functionality.

In both cases, the user receives an email with a link and the link directs to the base directory (as it should) but no modal pops for the user to either set or reset their password.

I have a single page react app and have included the identity widget script in my index.html.

At first I thought it might have something to do with my react-router, but I tried completely removing any private routes and nothing seems to make any difference with the issue.

Please advise

I’m unable to get a email confirm email itself. I got the email and it has no content. Is this working for you?

Scratch that, I did get a password reset email at least. And I could see the behaviour you describe. I do think it has to do something with React Router. I’d try to remove that from your all altogether to check if it works. If it does, you might have to use React Router to automatically open the widget when a hash string starts with #recovery_token=.

Thanks for the reply - I have completely removed the router from the deployed application and I am still getting the same behavior. When I click on the reset password link I am taken to the application but no reset password modal pops.

Can you elaborate on how to have the router open the widget? I looked through the documentation and couldn’t find anything on how to have the widget open for password set or password reset.


Hi @BrianSwedenberg this is open source software so you are welcome to open an issue but it works fine on other sites so this is likely a problem with code

1 Like

More specifically, it is something unique to your website’s layout/design/implementation (rather than our service).

While I wish it was caused by something obvious, that I could say “just try xyz”, we didn’t find anything like that while Sam and I looked together (we basically validated that you are loading the widget, and that the widget works as you describe it failing on your site, on other sites that are more vanilla), and I don’t anticipate that anyone else on our team will be able to advise further on this at this level (this is pretty far beyond our scope of support: Netlify Scope of Support - advising at the code level).

So - you can file an issue, try to fix, or try adjusting your site further, but I think something you do is likely to be the only thing that will change how this works on your site, at this point.

1 Like

Thank you for the responses - I appreciate that you both put time into this.

This was solved via an email exchange with the team - the issue was that my emails folder was not being included in the deploy. In order to fix I had to change my build command to …

npm run build && cp -r emails dist/