Missing Netlify Identity modal on password reset

Hi,
I can’t reset a new password (netlify CMS).
When i follow the link to reset the password
my project appear on a new tab
i see a token code after my project url, but,
the modal to reset the new password don’t appear.

Git Repo

https://gitlab.com/ferreiraf/315tz.git

Netlify Domain

https://315tz.netlify.app

I try on several broswers MacOS Firefox and Safari
and linux Firefox and Chromium. I try Normal pages
and incognito ones. But, no modal to reset the new password appear.

I already verify all this steps:

  • enable Git Gateway
  • invite user/ invite only

Could you help me ?
Thank you :slight_smile:

Can you confirm that you have the Netlify Identity Widget in your site.

  <script async="async" src="https://identity.netlify.com/v1/netlify-identity-widget.js"></script>

This ideally should be on every page but you could likely get away with just having it located on the page the access token (via email) links to.

Kyle.

Hi kyle,

Yes i have it in every head,

{# include netlify identity script #} <script type="text/javascript" src="https://identity.netlify.com/v1/netlify-identity-widget.js" defer async></script>

Could you share your Netlify site domain and a Git Repo if you have one.

here is my git repo
https://gitlab.com/ferreiraf/315tz.git

And my netlify side project url
https://315tz.netlify.app

1 Like

Can you confirm that is the correct repo link and it’s not private.

Oh sorry is setting private,
but is the correct repo.

Do i need to change the repo setting: private to public ?

For me, or any other forum member to help you, we need access to it. So yes please :slightly_smiling_face:

OK i’ll try to do my best.
I’m not a dev :upside_down_face:
How can i change settings in git lab to give you the access you need?

Maybe i can create a new repo with a public access?? :thinking:

Yep, you can clone the repo and give me access if that’s what your comfortable doing. I’m not familiar with GitLab but I’m sure you could add me privately to your repo so that only I have access to it, if you’re more comfortable with that :slightly_smiling_face:

Ok i clone a new repo with public setting
https://gitlab.com/ferreiraf/316tz.git

the netlify project is here
https://gifted-sammet-22d2ca.netlify.app

Is this ok ?

Yep, I’ll check that repo over for you now.

Ok thank you :slight_smile:

Try adding this to the head of: includes/layouts/default.njk

  <link rel="dns-prefetch" href="https://identity.netlify.com">
  <script async="async" src="https://identity.netlify.com/v1/netlify-identity-widget.js"></script>

My best guess is you added the identity widget to your admin page, but the identity emails are pointing at the root of your site. Here’s two ways on how to fix that: (one of which @kylesloper just posted :slight_smile:)

1 Like

Ok, thank you both.

i’ll try this tow possibility and come back to give you a feedback, asap
:+1:

1 Like

What i have done so far:

  • Try Kyle way, as possibility #1. But nothing change.

  • Try Tom way, as possibility #2.

#1 _ I delete the widget from my home page.
#2 _ In the head of my admin page (admin>index.html) i add the netlify widget.
The Kyle version:

#3 _ I’ve read the Tom post.
And i 'm confused. Do i need, now, to create in my admin directory four more files?

  • confirmation.html
  • recovery.html
  • invitation.html
  • email-change.html

I’m a very slow leaner, sorry :upside_down_face:

I tried accessing your cloned netlify site https://gifted-sammet-22d2ca.netlify.app and there is so result. Have you deleted it?

No, you don’t have to create any extra files. You just need the Netlify identity widget to be featured on the home page. As it stands currently, your site is not requesting identity.

Your site

A site with Netlify Identity
image

Just a quick one, have you enabled Identity in your Netlify UI?

Yes I delete it, because i make the changes in the private project.

i’m creating another public one with the last changes.

send you the new links asap

1 Like