Netlify not connecting to gitlab

netlify isnt connecting to gitlab when i choose gitlab as my git provider, it just keeps saying " Authorized" with the little netlify logo above it in the pop up but it never closes its self nor shows up on the main page when i close it my self or even before i close it

2 Likes

I have exactly the same, github works but gitlab fails.

if I inspect the popup’s log:

Uncaught TypeError: Cannot read properties of null (reading ‘postMessage’)

So it looks like netlify cant get the confirmation :frowning:

yeah same here, github works but gitlab doesnt

It seems to be a code bug of the netlify team.

Strange that they are ignoring the issue and not giving feedback.

1 Like

My Netlify account has the same error

experiencing the same here, it works for github but not gitlab.

Having same issue, when using Decap (Netlify) CMS with Gitlab auth

Still no resolution, same error as last week here. Same error on the pop-up window console from my other post.

Most replies/movement have consolidated in this post so I’ll keep following up here.

Hey folks, thanks for reporting this, and very sorry for the trouble!

We’ve opened an incident and you can follow along here: https://www.netlifystatus.com/incidents/95kbtr0bybb3

We’ve moved this incident to Resolved. Please let us know if you are still experiencing any issues.