Netlify identity reset password link did not update to new domain

Hello everyone,

I am having trouble resetting my password through Netlify identity widget.

I changed my main domain to a new url, but the link to reset the password still points to the old address.

I am not using any special template to reset the password so it’s the default one from Netlify that is being sent to users.

The invitation link, on the other hand, is pointing to the right domain.

Does someone have an idea on how I could resolve it?


Hey @Relisora! :wave:t2:

That’s a little odd. Changing your primary domain ought to update the Identity Service too, so if that’s presenting exactly that way, that could be a bug!

In the meantime, you could add a universal _redirects record to redirect all traffic from the old domain to the new one and carry all path/params. I think that might solve your issue in the short term since the reset token would still be present in the URL after the redirect.

https://old-domain.tld/* https://new-domain.tld/:splat 301!

Hope that helps!


Hey @jonsully !

Thanks for the quick reply, then I can only hope the bug gets fixed soon :slight_smile:

I set up url forwarding on the domain, it should be good enough for now. Thanks for the tip!

No problem. I’m actually going to tag @Dennis in here just for :eyes:. I haven’t attempted to reproduce this but would constitute a bug report if it’s indeed replicatable! :grin:

@Relisora, just one quick question to help point me in the right direction: have you triggered a new deploy after making a change to your custom domain settings? Just trying to find out what the parameters of the issue is to help us replicate the issue.


1 Like

Sure! I have not triggered a new deploy after changing my domain. I did however make a new deploy yesterday evening.
I just tried again to reset my password and the callback url is correct in the mail.
Maybe the new deploy fixed it but I cannot tell you for sure as I didn’t get idea to test right away.

Hope this helps :slight_smile:

1 Like

You will always need to re-deploy with a change, even just a readme to make any of your changes work :slight_smile: So the above deploy is the reason it now shows the correct domain.

1 Like