Netlify Identity gives 500 - Internal Server Error

Hi Recently my clients faced issues with login issue with netlify identity , I am using go-true js library to authenticate my users but since 3 days ago I am having this error “Internal Server Error - Request ID: 01G074G4PS4FVGSM6M8VYZB0MS” I have checked everything from my side , like billing accounts and other resources but cannot find any suitable answer . Can anyone guide me what is the workaround solution for this. Thanks :slight_smile:

1 Like


That’s an issue on our end and the engineers have been notified. There’s no workaround at the moment, so keep an eye out on this thread for further notifications.

Hi @hrishikesh, I’m having the same issue and I’ve had an issue very similar to this in the past. (Link) Tagging @hillary since she responded on that last issue. Are there any updates on when this will be resolved? And is there a reason why these major Identity issues (no access to Identity services at all for some period of time) are not displayed on the Netlify Status page?

Hi @utech-official-porta,

We’ve just been updated by the team. This should be working now. Can you let us know if you’re still having issues?

1 Like

This is a ‘catch-all’ error generated by the Web server. The first thing you need to know about an “Internal Server Error” is that the error can only be resolved by fixes to the Web server software. It is not a client-side problem meaning that the problem is not with your browser, your computer, or your internet connection. 500 Internal Server Error response code indicates that the server encountered an unexpected condition that prevented it from fulfilling the request. However, there are often ways to quickly get around the problem:

  • Very commonly, incorrect permissions on a file or folder that contains one of the scripts causes this this error.
  • Reload your browser (press F5) or try with another one. The chances that the page will load when you refresh your browser are low, but still, it’s worth giving it a try.
  • Try to clear your browser cache. If the page that shows 500 error is cached, after the cache is cleared, the browser will request a new version of the page.
  • Come back later. The webmaster may fix the server issue in the meantime.
  • A Coding Error in .htaccess. While not as common, be sure to check that your site’s .htaccess file is properly structured.
  • Contact the website owners. The last remaining option is to get in touch with the person responsible for maintaining the website.

Thanks for sharing, @elonjigar!

I am having 500 errors from MongoDB now. It seems like it only happens when I run a query with a populate. Works fine on my development site, which is running Windows 11. I am using Nuxt 3/Nitro. Any ideas would be appreciated.

Hi esscubed, glad you found us :wave:t6: before we can help you, we need a little more information on the issues you are facing.

First, have you looked through this resource? It is a compilation of all of our build and deploy resources. This is a good starting point.

If you have worked through those guides and are still encountering issues please share the following information:

  • the name of your build instance: “
  • what you have already tried
  • any error messages you have received in your terminal window or in the developer console

I “solved” the problem by not doing a number of queries in a loop. It seems like there are latency problems with Mongodb. I am not working with a large dataset, so I just pulled dow all the data outside the loop and used code to search the resulting array.

This is not a good solution for a large dataset.

The build instance is

The last non-working build was any one before ‘redid admin to not use query’
The error is normally a 500 on the call to Mongodb. The rest of the app works fine and this part fails intermittently.

I have to admin my ignorance, but I have no idea how to view a terminal window for the server side of a static nuxt 3 app. I have a feeling that I must upgrade to a higher level to do that, right?

I have tried a number of different approaches with the query inside the loop without success. I believe that it did work without a .populate(). It always works on my dev environment. Since it is intermittent, I gotta believe it is a timing/latency issue.

Thanks for any help,


1 Like

Actually, the problem is not solved completely. A fetch still hangs up occasionally. The data entries are very small…10-20 entries in each of 3 collections and maybe 5 fields in each. I have three alternatives:

  1. Try the first pay tier of Netlify in hopes that the extra resources will mitigate the problem
  2. As mentioned, add indexes to the MongoDB schema. Currently, I have none.
  3. Move over to Fauna.

Any suggestions would be welcome.

On Pro and above plans, you can request Function region closest to your database. This can speed things up sometimes. We primarily support, 4 regions in US, 1 in EU and 1 in APAC. So if your mongo instance is in APAC and you’re connecting from US (default), that’s going to add latency. This could be a part of the solution if not entirely.