Netlify hosting with external Custom domain name issues

I removed the _redirects file, now https://borisbelloc.netlify.com/ can be accessed but www.borisbelloc.com still show the same error message :neutral_face:

Any idea what I did wrong ?

Am I supposed to do something more than just giving the netlify name server to Gandi ?
As show in second picture, Netlify detect de DNS

for me, both urls show same content , you can see URL in below screenshot

thanks for your answer;

it’s now working; i changed nothing :grimacing:

DNS changes can take time to propagate. Perhaps that is all that was happening. Regardless, glad to hear things are working better now!

for me it is a different story,

i have pointed domain to netlify ( vueadmintemplate.com)
and for a project/site, i made a subdomain like vue-dark.vueadmintemplate.com

when i go to domains tab, i can see sub-domain with record type netlify
and it is more than 10days, that site can’t be opened at all.

Hi @seenu, it looks like the record wasn’t complete for some reason. I re-created it and it looks like it’s working now. Let me know if you still see issues with that subdomain.

1 Like

thanks for that, but i have other sub-domains as well having same issue

ex: vue-light.vueadmintemplate.com
boxed.vuejslaravel.com

Got those fixed up as well.

Hey i have exactly the same issue with my subdomain (www.linkapp.zone)

Hi, @Orsbert, this domain isn’t correctly configured for Netlify DNS at this time.

The Netlify DNS name server (NS) records were added:

$ dig linkapp.zone NS  +noall +answer

; <<>> DiG 9.10.6 <<>> linkapp.zone NS +noall +answer
;; global options: +cmd
linkapp.zone.		3576	IN	NS	dns4.p01.nsone.net.
linkapp.zone.		3576	IN	NS	dns3.p01.nsone.net.
linkapp.zone.		3576	IN	NS	dns2.p01.nsone.net.
linkapp.zone.		3576	IN	NS	dns1.p01.nsone.net.
linkapp.zone.		3576	IN	NS	ns74.domaincontrol.com.
linkapp.zone.		3576	IN	NS	ns73.domaincontrol.com.

However, adding our name servers doesn’t make them the authoritative name servers for this domain. Because they were added instead of replacing the authoritative name servers, they won’t actually be used.

If you check the WHOIS data for the domain, you can see the authoritative name servers are just the last two above:

$ whois linkapp.zone | tail -n 27
Domain Name: linkapp.zone
Registry Domain ID: fb76a06b2cb04b888d6aa1e17fc2a513-DONUTS
Registrar WHOIS Server: whois.godaddy.com
Registrar URL: http://www.godaddy.com
Updated Date: 2020-06-02T22:00:31Z
Creation Date: 2020-06-02T22:00:30Z
Registrar Registration Expiration Date: 2021-06-02T22:00:30Z
Registrar: GoDaddy.com, LLC
Registrar IANA ID: 146
Registrar Abuse Contact Email: abuse@godaddy.com
Registrar Abuse Contact Phone: +1.4806242505
Domain Status: clientTransferProhibited http://www.icann.org/epp#clientTransferProhibited
Domain Status: clientUpdateProhibited http://www.icann.org/epp#clientUpdateProhibited
Domain Status: clientRenewProhibited http://www.icann.org/epp#clientRenewProhibited
Domain Status: clientDeleteProhibited http://www.icann.org/epp#clientDeleteProhibited
Registrant Organization: LinkApp
Registrant State/Province: Central
Registrant Country: UG
Registrant Email: Select Contact Domain Holder link at https://www.godaddy.com/whois/results.aspx?domain=linkapp.zone
Admin Email: Select Contact Domain Holder link at https://www.godaddy.com/whois/results.aspx?domain=linkapp.zone
Tech Email: Select Contact Domain Holder link at https://www.godaddy.com/whois/results.aspx?domain=linkapp.zone
Name Server: NS73.DOMAINCONTROL.COM
Name Server: NS74.DOMAINCONTROL.COM
DNSSEC: unsigned
URL of the ICANN WHOIS Data Problem Reporting System: http://wdprs.internic.net/
>>> Last update of WHOIS database: 2020-06-15T08:00:00Z <<<

Lines above which show the name servers are:

Name Server: NS73.DOMAINCONTROL.COM
Name Server: NS74.DOMAINCONTROL.COM

You will want to replace these name servers at GoDaddy with the name servers listed in Netlify DNS. That is one way to resolve this.

The other possible solution is to delete the NS records for the name servers at Netlify and use the external DNS instructions instead.

If there are questions about either solution, please let us know.

Hi, i came across your answer and wondering if I am facing the same situation:

Any advice would be very good. Thanks

i think it just needed some extra time, @zahiernasrudin:

I’m also having the same issues as well… I’m using name.com to host my domain (thesoulmerch.com) but even though I’m pointing to netlify servers, I still get an error when visiting my website. Any help will be greatly appreciated!

!

Hey @Hamze,
I looked into this and there seems to be an issue on the name.com side with this domain that you will need to resolve with them :frowning:

When I check host, I get an error for the apex domain, www. subdomain, nameservers- everything. Here’s just one query:

% host www.thesoulmerch.com
Host www.thesoulmerch.com not found: 2(SERVFAIL) 

You can also see several errors here related to the domain itself:

Let us know once you’ve connected with name.com to resolve those issues and we should be able to help from there!

thank you so much for your help! I’ll let you know asap

Alright I’m back! Everything should be good on name.com’s side, and they told me that all I need to do is add my DNS records with you.

I’m a little confused on what my next step should be though. I read an article from Netlify about adding DNS records with CNAME or A and I’m still not so sure what to do. (My domain should point to https://soulmerch.netlify.app for reference) Thanks for your help!!

Hey @Hamze,
Alright let’s give it a shot then :slight_smile:

You can either let name.com host your DNS records or let us do it with Netlify DNS. Since you sent a screenshot of the name.com DNS panel, let’s stay over there, but know that you can switch any time. In that panel, you’ll want to create two DNS records:

And note that, to get the best performance from our CDN, we do recommend setting the www subdomain to be your “primary” domain on the Netlify side. Here’s where you’d switch that:

Here’s the direct link to that view: https://app.netlify.com/sites/soulmerch/settings/domain#custom-domains

Let us know if you run into any issues after that!

Hi, im having the same issue. My domain is registered at gandi.net and i host my 4 applications on Netlify :

So I have 3 different sub-domains (api, staging and api-staging).
Both of my APIs seems to work, but my front-ends not. I have configured the DNS records for GandiMail (2 MX and 1 TXT), and I also have pointed my Gandi name servers to Netlify ones (as we can see in the screenshot).

It worked for 10min then i couldn’t access both my front-ends.

Maybe it’s a question of delay of propagation ?

But any clue could save me :smiley:

Thank you in advance for reading me :slight_smile:

But what is really weird, it’s that it has worked for 10min !

Hi, @dev-mathiasmortelman. I checked both mathiasmortelmans.com and www.mathiasmortelmans.com and both are working when I test:

$ curl --compressed -svo /dev/null https://www.mathiasmortelmans.com/  2>&1 | egrep '^(<|>)'
> GET / HTTP/2
> Host: www.mathiasmortelmans.com
> user-agent: curl/7.79.1
> accept: */*
> accept-encoding: deflate, gzip
>
< HTTP/2 200
< age: 0
< cache-control: public, max-age=0, must-revalidate
< content-encoding: gzip
< content-type: text/html; charset=UTF-8
< date: Tue, 21 Jun 2022 05:54:05 GMT
< etag: "4fb62e3017c9c2070bc7e8e3a6cc4a48-ssl-df"
< server: Netlify
< strict-transport-security: max-age=31536000
< vary: Accept-Encoding
< x-bb-except: Cookie=__prerender_bypass,__next_preview_data
< x-nf-request-id: 01G62D6FX6CNJ1F5TTSP7BK0NY
<

$ curl --compressed -svo /dev/null https://mathiasmortelmans.com/  2>&1 | egrep '^(<|>)'
> GET / HTTP/2
> Host: mathiasmortelmans.com
> user-agent: curl/7.79.1
> accept: */*
> accept-encoding: deflate, gzip
>
< HTTP/2 301
< age: 0
< cache-control: public, max-age=0, must-revalidate
< content-type: text/plain
< date: Tue, 21 Jun 2022 05:54:14 GMT
< location: https://www.mathiasmortelmans.com/
< server: Netlify
< strict-transport-security: max-age=31536000
< x-bb-except: Cookie=__prerender_bypass,__next_preview_data
< x-nf-request-id: 01G62D6RD136MKDV9XCE90X4FB
< content-length: 49
<

If there is some URL not working for you, would you please send us the x-nf-request-id header for the incorrect response?

There more information about this header here:

If that header isn’t available for any reason, please send the information it replaces (or as many of these details as possible). Those details are:

  • the complete URL requested
  • the IP address for the system making the request
  • the IP address for the CDN node that responded
  • the day and time of the request (with the timezone the time is in)

In the two responses above the headers were 01G62D6FX6CNJ1F5TTSP7BK0NY and 01G62D6RD136MKDV9XCE90X4FB. That information will help us to debug this issue.