Home
Support Forums

Netify website + Netlify CMS are not loading new content without refresh

Hey, my website is build witg gatsby and netlify CMS and is deployed to netlify. I have recently noticed that it dioes not reload new content whne it is updated in the cms. I have followed different threads online about what might be the cause, but withoour any luck. I do not have any service workers on the website, and do not use gatsby off line plugin, which seems to be the problem in many cases that I found. One can only see new content if the page is hard refreshed. I have allowed more than 24 hours to pass to see if it is natural browser behaviour, and browser cashing, but it never updates, please help.
The website is connected to. custom domain, https://www.hahastudio.se,
thanks for all the help in advance

@viktorijavalsoe Please clarify: Do you mean that you are making changes to the code but they are not being published (a problem with the build process), or that you are publishing your changes but they are not showing up in your browser (most likely a local caching issue)?

If it’s the second, have you tried visiting your site using a new private / incognito browser window? Have you tried “previewing” your site with an online service such a GTMetrix?

Hey Greg, it is the second, the changes to the CMS are not showing up.
If I view it in incognito window, i can see the changes, same if i preview it in GTMetrix.
But these means that if you are a returning customere to a website, you will never get to see changes unless hardd refresh :frowning:

@viktorijavalsoe This sounds to be a local caching issue, in which case other visitors may be seeing your up-to-date content. In other words, this is not an issue with Netlify. If the content is there for some browsers (such as incognito windows and GTMetrix), then the problem is elsewhere.

I checked one of your images as an example, it has Cache-Control: public,max-age=604800 as a header. It does not, however, have any form of asset hashing in place, so if you update the image, the browser will pull the old image from the cache instead of fetching the new one. It will keep doing that until 604800 seconds have expired since the initial fetch.

Here’s a pretty elaborate article on the subject:

By the way: pretty amazing renders on your site, nice!

Hey @tomrutgers tahnk you so much for bringing taht to my attention. I bet that is where the problem is, thank you so much

the problem was that i added gatsby-plugin-remove-fingerprints plugin as an attemt to optimise the website preformance that i found in one of the netlify articles, but obviously it did something unintended. Removing the plug in fixes the issue

2 Likes

I have the same issue

For some reasons, my site data doesnt update content from the cms. A brief illustration:
When you visit unitedbelieversmission.org, the content does not sync with what is on the cms. When you navigate to lets say United Believers Mission Inc. and navigate back to unitedbelieversmission.org/ (without reloading the page), you see the updated content. When you reload, you dont see it. And then it loops all over.
I tries using the ‘clear cache and deploy’ button on netlify and visiting the page after that, I get to see the updated content. At this point, when a new data is updated on the cms, it does not reflect on the website anymore. And then it begins all over again.