Firefox doesn't load home page properly

Site name: elated-lamarr-b6d2a0
Site url:

The site deploys and builds correctly, but the home page breaks (doesn’t load) - the whole page gets stuck and nothing loads correctly. It seems it gets to a point of loading, then just freezes - even the browser itself can’t be used - it needs to be closed and re-opened.

This happens:

This issue can not be replicated in local.
We also tried to re-create the whole homepage, remove the video, switch the home page to a different node.

Nothing works - can anyone be so kind to help? The client is really unhappy at the minute :frowning:

I have reason to believe it is something to do with firefox cache. When I opened firefox disabled cache, loaded the site and refreshed loads with no cache, it works. As soon as I enabled cache, there was an issue. I was using Firefox 78.0.2 (64-bit) also tried 82, what version are you on please?

I don’t have any proof but suspicion from an old project I worked on could be jquery being pulled from a URL, could you import jquery min js into your code and try it? It also looks like you pull in fontawesome and bootstrap from a CDN, you could try putting those directly into the code?

As a side note: On page load the site is transferring 38MB of data, 34 of that being the video, you should really lossless compress that, you’ll cut a lot.

Hi, @ngoclx. I wanted to point out that we can also troubleshoot this privately if you prefer as this is site is part of a Pro level account. ​Please let us know if this is preferred and I’ll transfer this issue to our support helpdesk.

If you want to troubleshoot this here, we need to be able to track the HTTP response with this issue. One way to do this is to send us the x-nf-request-id header which we send with every HTTP response.

There more information about this header here:

Note, please send the header for the HTTP response which has the issue. For example, if the issue is happening on the video file, please send us the x-nf-request-id header for that response, not for the HTML response.

If that header isn’t available for any reason, please send the information it replaces (or as many of these details as possible). Those details are:

  • the complete URL requested
  • the IP address for the system making the request
  • the IP address for the CDN node that responded
  • the day of the request
  • the time of the request
  • the timezone the time is in

You might also make a HAR file recording of the issue and send that to us as it will normally contain all of the information above.

If there are questions about any of this, please let us know.

Hi @luke - I would really appreciate if you can look into this for us.

I’ve uploaded a zip here:

You will see:

  • shp-home-firefox.har -> this is when the issue happens, on first load of the home page directly from a private window in Firefox

  • SHP-contactus-firefox.har -> this is when i visit another page directly from a private window in Firefox - the issue doesn’t happen here

  • SHP-home-from-internal-page-firefox.har -> this is when i go to the home page from the contact us page in Firefox - the issue doesn’t happen here

Let me know if you need anything else from us.

Much appreciate your help!

On a different note @luke - how can I directly create a support ticket? I could not find a way, that’s why I posted in the community.


Hi, @ngoclx.

We have sent you an email to the email address associated with your Netlify account, and we’ll communicate with you through that email to continue resolving this issue. (Please note that for security reasons, we will not contact you at email addresses not listed in your Netlify account.)

Also, please let us know with a reply here if you don’t receive a message from us.

I’ll be following this for a general update on the solution as it seemed interesting! :slight_smile:

Thanks @luke!

I have not received any email as of yet - I have also realised I don’t get any notification when someone responds to this thread.

Checked spam, not there either!
This is quite important to fix so I would really appreciate any help on it.

Thank you,

Hi @luke,

I haven’t received any reply to my email or Could you please double-check to what email have you sent the reply/ticket?

Kind regards,

Hi, @ngoclx. I’ve made sure both or were included on the support ticket (as all the information has been posted here already) and confirmed another email was sent to both email addresses.

If you don’t see an email at either location please please let us know. I’m also happy to keep troubleshooting here.

There was only one error in the HAR file named shp-home-firefox.har and that was for this URL:

Can you confirm if this is the asset not loading which causes the page not to load?

The domain is hosted with another service. We are not able to troubleshoot that asset load failing because that isn’t an asset hosted at Netlify.

I don’t know if this is the cause of the page not working or not but it is the only error in the HAR file where the issue was reported. All other responses in that HAR file are 200 responses.

Fontawesome is now hosted on netlify (in codebase), but the result is the same.

Do you have any other ideas about this?

I checked my packages again but looks okay. Really weird!

@braid/vue-formulate”: “^2.4.3”,
@gridsome/plugin-critical”: “^0.2.0”,
@gridsome/plugin-google-analytics”: “^0.1.2”,
@gridsome/plugin-sitemap”: “^0.4.0”,
@gridsome/source-wordpress”: “^0.5.0”,
“aws-sdk”: “^2.748.0”,
“axios”: “^0.20.0”,
“bootstrap”: “^4.5.2”,
“bootstrap-vue”: “^2.16.0”,
“dayjs”: “^1.9.1”,
“gridsome”: “^0.7.0”,
“gridsome-plugin-htaccess”: “^0.2.1”,
“gridsome-plugin-robots-txt”: “^1.0.2”,
“jquery”: “^3.5.1”,
“vue-plugin-load-script”: “^1.3.2”,
“vue-responsive-video-background-player”: “^1.1.2”

ok, it was what I said! you guys do have issues with the plugin @gridsome/plugin-critical. I removed it and the website works properly now for FF.

Thank you for your support!

1 Like