DNS verification failed: site doesn’t appear to be served by Netlify

Hi there
I have 2 domains which points now to Netlify’s NAMESERVERs.
It has been done over one month ago.
One of them pricetegrity.de works just fine and I was able to assign SSL certificate via Netlify panel, the website is accessable and no problems are there.
However, the second one pricetegrity.com does not work at all and could be reached only via internal name, given by Netlify (prictegritycom.netlify.app).
DNS verification failed

  • pricetegrity.com doesn’t appear to be served by Netlify*
    Despite I can see ‘Netlify DNS’ badge in the ‘Custom Domains’ row.

All the settings are identical for both domains.
I’m wondering what could be wrong here and how can I solve it?

Hi, @amykhailovskyi, and welcome to the Netlify community site.

The domain pricetegrity.com is configured to use these DNS servers:

$ whois pricetegrity.com | grep "Nameserver"
Nameserver: dns1.p03.nsone.net
Nameserver: dns2.p03.nsone.net
Nameserver: dns3.p03.nsone.net
Nameserver: dns4.p03.nsone.net

However, the actual name servers for this domain for Netlify DNS are ones below:


This is why DNS is isn’t working for this domain. Would you please try changing the name servers to the ones listed for the domain here (the link below)?


Those are the p01 (not p03) domain names. If there are any questions, please let us know.

1 Like

Hi Luke,
thanks for taking care about my issue.
Looks like my bad, don’t know where I got *.p03.nsone.net from.
I’ve just updated NAMESERVERs, will check it later and reply here.

Best regards,

@amykhailovskyi Wow, four hours later and only Level3 has picked up on the change. This is what Google sees currently, which is nothing.

dig pricetegrity.com -t NS

; <<>> DiG 9.10.6 <<>> pricetegrity.com -t NS
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 60102
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;pricetegrity.com.		IN	NS

;; Query time: 11 msec
;; WHEN: Fri May 01 07:49:44 PDT 2020

Nothing else to do now except wait for the changes to propagate.

1 Like

@amykhailovskyi You might want to double-check your DNS settings with IONOS, because even 24 hours later only Level3 shows the Netlify name servers. The other major DNS providers are showing blank. I’ve never seen that before. Maybe make a small change to your DNS settings and set the TTL as low as possible to trigger a new propagation?

On IONOS I can see warning which says that IONOS-DNS settings are inactive when I use not their NS.
Maybe it should be updated in Netlify settings panel?
Sorry, I’m not so good in this topic.

No apologies necessary! DNS is a real pile of :spaghetti:

@amykhailovskyi, when I run:

$ host pricetegrity.com
pricetegrity.com has address
pricetegrity.com has IPv6 address 2604:a880:2:d0::1546:5001

I don’t think that IPv6 record is ours. Can you see if you can delete it (address 2604:a880:2:d0::1546:5001) at IONOS? I’m wondering if that’s getting in the way here, similar to:

@jen IPv6 I’ve enabled in Netlify. I will try to find out how to deactivate it.

@jen I’ve removed pricetegrity site and domain from Netlify and recreated that from scratch as I did not find how to deactivate IPv6 DNS and I have doubts that I did not spoil settings there.
Hope it will work soon

Hey @amykhailovskyi, we’ve dug into this further and see that your DNS has not resolved itself even though you seem to have done things correctly on the Netlify end :frowning:

For example, this is correct:

$ host pricetegrity.com
pricetegrity.com has address  <---- Netlify
$ host www.pricetegrity.com
www.pricetegrity.com has address  <---- Netlify

But this is not good and suggests an issue with nameservers, not with records that you may have entered in our UI:

$ host -t caa pricetegrity.com
pricetegrity.com has no CAA record

You will most likely need to sort this out with your previous DNS host. Do you know who that was before you moved to Netlify DNS hosting? The errors in red here will need to be resolved by them:

I’m sure this is not what you wanted to hear, but it’s what we found after quite a bit of research. Please let us know if we can help with anything else at this point.

Hi @jen,
You already did much to find out the reason, I really appreciate your effort.
Just contacted support of my previous hosting and they say that all the changes (NS) was applied on their side and they can’t do anything else.

But what is interesting, that pricetegrity.com is available from different regions. I’ve asked my friends from another countries to open it and some of them can see it, for rest - “This site can’t be reached”. It also happened to me, from my laptop I can’t navigate, from smartphone I can.

Maybe this can give you an idea what is wrong?

@amykhailovskyi Even after all this, I’m still seeing that only Level3 knows who you are:

dig @ pricetegrity.com -t NS

pricetegrity.com.	3463	IN	NS	dns1.p03.nsone.net.
pricetegrity.com.	3463	IN	NS	dns2.p03.nsone.net.
pricetegrity.com.	3463	IN	NS	dns3.p03.nsone.net.
pricetegrity.com.	3463	IN	NS	dns4.p03.nsone.net.

( is the IP address for one of the main Level3 public DNS resolvers. If you replace this with any of your four Netlify DNS entries you will see the same output, which means that Netlify is already set up to this extent.)

Who is your registrar? Ionos? Verisign? Whichever it is, that’s where you need to get this resolved. As @jen pointed out, so far your settings / entries with Netlify look OK. You just need to get your registrar to direct traffic to Netlify so Netlify can do its thing.

FWIW, I’ve never seen anything like this beyond the first few minutes / hours after creating a new domain name.

Thank you @gregraven, yep it is IONOS.
I’m trying to explain them all I got from you guys, but they simply say that settings are correct and the rest is done on Netlify’s side.
I will contact them again :slight_smile:

@amykhailovskyi Bummer. Sorry.

Well, I’ve tried to reset all manually done changes, revert back NS and change again to Netlify’s one.
The issue still in place.
But I was just wonder if there is no problem with domain by itself and put back original NS.
Using the link provided by @jen (https://dnsviz.net/d/pricetegrity.com/dnssec/) and it shows no errors now.
Could be that the issue is on Netlify side?

@amykhailovskyi Right now, it appears that you are NOT using Netlify for the DNS of your website:

pricetegrity.com.	86400	IN	NS	ns1097.ui-dns.de.
pricetegrity.com.	86400	IN	NS	ns1049.ui-dns.org.
pricetegrity.com.	86400	IN	NS	ns1066.ui-dns.com.
pricetegrity.com.	86400	IN	NS	ns1126.ui-dns.biz.

Exactly, this is what I mean. Setting NS back to IONOS makes domain recognizable

@amykhailovskyi Ah, I didn’t understand that part.

Are you serving the same content on pricetegrity.com as on pricetegrity.de, or different content?

pricetegrity.com now shows a generic parking page for IONOS, so the DNS still isn’t right even with different DNS servers. Am I missing something?

I did not deploy anything to pricetegrity.com yet, but should be same content.
I’m just trying to figure out the reason of why DNS is not visible neither for google nor for cloudflare when changing NS to Netlify

@amykhailovskyi Then why not just add pricetegrity.com and www.pricetegrity.com to the domains of pricetegrity.de and be done with it?

Obviously, you would also have to make certain that pricetegrity.com points to the same Netlify DNS as pricetegrity.de:

pricetegrity.de.	3600	IN	NS	dns1.p03.nsone.net.
pricetegrity.de.	3600	IN	NS	dns2.p03.nsone.net.
pricetegrity.de.	3600	IN	NS	dns3.p03.nsone.net.
pricetegrity.de.	3600	IN	NS	dns4.p03.nsone.net.

No sense in making more work for yourself than you have to.