DNS record conflict

Thank you for providing an awesome service.
I recently shifted the entire DNS propagation from Dream host to Netlify so I may host a subdomain here. However my primary domain A/CNAME records and MX records need to be pointed elsewhere. It’s been a day and the sites are still disconnected. I believe this is due to a previous record of A and CNAME still connecting and old non-existent deploy (agitated-visvesvaraya-377183.netlify.app) to my main domain.

Thank you

None of the DNS records above are propagating. Please help.

@reddy2go Welcome to the Netlify community. We’re going to need your custom domains and perhaps your subdomain names in order to help troubleshoot this issue.

1 Like

@reddy2go This is a pretty wild set-up. I checked the first two domains and the IP address in a browser and nothing loaded. Maybe the target has to be valid and running before propagation occurs?

So most of them are required for tutanota email

  • MX mail.tutanota.de.
  • TXT “v=spf1 include:spf.tutanota.de -all”
  • s1._domainkey CNAME s1._domainkey.tutanota.de.
  • s2._domainkey CNAME s2._domainkey.tutanota.de.
  • _dmarc TXT “v=DMARC1; p=quarantine; adkim=s”
  • _mta-sts CNAME _mta-sts.tutanota.com.
  • mta-sts CNAME mta-sts.tutanota.com.

@reddy2go Your entries above look to be from Netlify DNS, but your DNS seems to be handled elsewhere:

reddy2go.com. IN NS
reddy2go.com. 3581 IN CNAME collectednotes.com.
collectednotes.com. 21599 IN NS ns-cloud-a1.googledomains.com.
collectednotes.com. 21599 IN NS ns-cloud-a2.googledomains.com.
collectednotes.com. 21599 IN NS ns-cloud-a3.googledomains.com.
collectednotes.com. 21599 IN NS ns-cloud-a4.googledomains.com.

Have you tried making your DNS changes at googledomains.com?

that’s strange. Those exact records were working on dreamhost dns. Can I delete those records and try again?

@reddy2go Given the complexity of your set-up, I wouldn’t presume to tell you what needs to be deleted where, but somehow you need to get all of your DNS records in one place, except for those (such as at Netlify) that direct requests to your assets to the right place.

Thank you @gregraven I just deleted all the records and added them again. It was operational in minutes after that. Much thanks for your efforts.

Hi, @reddy2go, so everything is working correctly now? If not, please let us know and we’ll keep troubleshooting.

Yes @luke please consider the issue resolved. Deleted and re-adding the records worked.
Thanks again