DNS name still not working, even though all settings look correct

Hello,
I’m having issues resolving a fresh domain name for my my site.

Here the details:

Domain: sanacijedimnikov.net
Netlify site: https://branko-zalorak.netlify.app/


Whois output

$  whois sanacijedimnikov.net

...
Name Server: DNS1.P06.NSONE.NET
Name Server: DNS2.P06.NSONE.NET
Name Server: DNS3.P06.NSONE.NET
Name Server: DNS4.P06.NSONE.NET
DNSSEC: unsigned

DIG output

$ dig sanacijedimnikov.net NS +noall +answer


; <<>> DiG 9.10.6 <<>> sanacijedimnikov.net NS +noall +answer
;; global options: +cmd
sanacijedimnikov.net.   2651    IN      NS      dns4.p06.nsone.net.
sanacijedimnikov.net.   2651    IN      NS      dns3.p06.nsone.net.
sanacijedimnikov.net.   2651    IN      NS      dns2.p06.nsone.net.
sanacijedimnikov.net.   2651    IN      NS      dns1.p06.nsone.net.

Host output:

$ host -a sanacijedimnikov.net

Trying "sanacijedimnikov.net"
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44341
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 8

;; QUESTION SECTION:
;sanacijedimnikov.net.          IN      ANY

;; ANSWER SECTION:
sanacijedimnikov.net.   3569    IN      NS      dns4.p06.nsone.net.
sanacijedimnikov.net.   3569    IN      NS      dns1.p06.nsone.net.
sanacijedimnikov.net.   3569    IN      NS      dns2.p06.nsone.net.
sanacijedimnikov.net.   3569    IN      NS      dns3.p06.nsone.net.

;; ADDITIONAL SECTION:
dns1.p06.nsone.net.     68862   IN      A       198.51.44.6
dns2.p06.nsone.net.     4786    IN      A       198.51.45.6
dns3.p06.nsone.net.     61796   IN      A       198.51.44.70
dns4.p06.nsone.net.     3509    IN      A       198.51.45.70
dns1.p06.nsone.net.     74690   IN      AAAA    2620:4d:4000:6259:7:6:0:1
dns2.p06.nsone.net.     1148    IN      AAAA    2a00:edc0:6259:7:6::2
dns3.p06.nsone.net.     76114   IN      AAAA    2620:4d:4000:6259:7:6:0:3
dns4.p06.nsone.net.     73486   IN      AAAA    2a00:edc0:6259:7:6::4

NSLookup response

$ nslookup sanacijedimnikov.net
Server:         192.168.0.1
Address:        192.168.0.1#53

Non-authoritative answer:
Name:   sanacijedimnikov.net
Address: 192.64.119.103

Flushed DSN via Google Flush Tool

No DSNSEC active

Flushed local cache (not that its relevant here, just for completeness)
$ sudo dscacheutil -flushcache; sudo killall -HUP mDNSResponder


Screenshots:

DNS records in Netlify:

CURL requests are timing out after 75 seconds with no response… Netlify UI shows all things are correctly setup, so I’m not sure what to change. The configuration was setup 14 hours ago, but it was a fresh domain setup, so it should not take that long and also the output from all the unix tools kinda indicates, that the DNS change was already propagated. What else can I try out to fix this?

Thanks in advance,
Roman

Since this is a new account, I can only include a single screenshot.

So here are the other ones:

Required nameservers:

Configuration in Namecheap.com:

I have no issues accessing sanacijedimnikov.net or www.sanacijedimnikov.net

1 Like

Wow, really? It is not working in Europe at all. I’m trying it from Slovenia, and it is just timing out.

Just did a test and requested it over my mobile provider, and indeed, the DNS resolution seems to work.

So, maybe my router is caching the DNS resolution or my Slovenian internet provider is doing something funky. Either way, thank you very much, I guess the issue is not my configuration but something on the wires. Will dig deeper!

This is certainly possible. Possibly even your computer/browser. Try a different browser, use a private/incognito window, flush DNS…

Indeed, restarting the internet router solved this issue. Wow, all those crazy caches everywhere…

Thanks!

2 Likes