DNS not fully resolving

PROBLEM: Domain was added on 7 Feb and is still not fully resolved.

-domain: darlenesbarbershop.com
-using namecheap as custom DNS
-DNSSEC Status is off
-recently we transferred domain from one team to another and it was rather an unorthodox process (temporarily moved to github pages and then moved back to netlify when it was finally moved to the new team)
STEPS Taken to resolve:
-I have tried dig, everything seems to look okay there
-I currently have p05 and p01 nameservers added (thought this might be the problem), the netlify instructions only had me add the p05 nameserver, but I am out of sane solutions at this point :slight_smile:
-the only error message I get is when I try to renew the SSL/TLS certificate in netlify
DNS verification failed

We can’t provision a certificate until your DNS configuration is pointing at the Netlify servers and the changes have propagated.

whois darlenesbarbershop.com | grep "DNSSEC"
   DNSSEC: signedDelegation
   DNSSEC DS Data: 7309 13 1 60D13E8766038AADB26C57687D680DD7A7AEB839

Seems like DNSSEC is on for your domain.

What a find! So on my dashboard, DNSSEC was marked as off. I reached out to namecheap support and in fact this was a bug. They had to fix it. As soon as this was fixed, everything resolved within minutes. I refreshed the netlify https certs successfully as well.