My DNS records does not update

Hi everyone,

My netlify site is and my domain is
I set the nameservers as required and verified from
Here some of the servers does not answer but others are OK.
However when I check A records the results differs from server to server. The domain does not work. Also when I try to verifiy DNS for SSL certificate I got the error: “* doesn’t appear to be served by Netlify”

I tried to flush cache by google’s tool but this did not help. This is a long term issue.

What should I do?

@ozanmk Welcome to the Netlify community.

It appears that something got hung up somewhere. I’m seeing only two of the six top DNS resolvers returning information about your custom domain name.

Have you tried deleting your domain via the Netlify Domains dashboard, and re-adding it? This seems to have worked in other similar cases, and in any event it takes only a couple minutes.

If you do this, remember that when you re-add your domain to Netlify that you may be assigned four different DNS servers than you had originally, so you’ll need to verify with your registrar that you have the correct DNS servers entered.

thanks @gregraven.

yes I tried removing and re-adding the domain but it did not help. Also I deleted all my custom DNS records.

As you mentioned nameservers are changed and I realized that while I was writing the original post. Then I updated them.

@ozanmk And now it’s working. All you have to do is wait for these DNS changes to propagate so you can enable HTTPS in your Netlify dashboard.

@gregraven I tried with different computers which use different DNS but it cannot be resolved. I made changes more than 24 hours ago, I recently changed nameservers only and they seems to be they are propagated.

@ozanmk Well, you must have changed something else, because now your DNS is not propagated properly and your site isn’t loading.

@gregraven No I did not changed anyting except NS recently, I removed and reconfigured the DNS more than 24 hours ago. But this problem is much older than that, my DNS setting is not working for months, but I did not have time to fix that. My updates do not propogate, but I do not why and what should I do.

@ozanmk OK, well something is going on because I originally saw a different setup, and your site wasn’t loading. Then I saw the setup change and you site loaded. Now I see what could be a third different setup.

My recommendation would be to go back through everything and make certain that you have your settings correct. When I dig your custom domain, it comes back with as handling the DNS. When I check with whois, it comes back with both and as handling the DNS. At least one of these is incorrect, and neither of them is propagated.

Perhaps you could supply some screen shots of your Domains -> DNS records entry with Netlify, your Settings -> Custom domains settings, and whatever DNS settings you have with your registrar?

@gregraven I added current settings below:

and this is from registar

@ozanmk These look good. What about the Netlify settings in Settings -> -> Domain management -> Custom domains settings?

@gregraven here it is

@ozanmk Everything looks good in these screen shots, but your setup seems to have changed again. If you’re not making any edits, there is something really weird going on. I now don’t see any A records, and your name server records are still not propagating. At least you have one consistent set of DNS servers, though. Because you’ve already tried deleting and re-adding everything, I think you’re going to have to wait for one of the Netlify support techs to look into this. Sorry.

thanks for your all help @gregraven

@ozanmk I just noticed something … even Netlify DNS doesn’t know about your site. Therefore, the problem does seem to be with Netlify, and not elsewhere.

dig -t NS

; <<>> DiG 9.10.6 <<>> -t NS
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 46899
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1232
;			IN	NS

;; Query time: 25 msec
;; WHEN: Tue Sep 01 19:30:12 PDT 2020
;; MSG SIZE  rcvd: 43

Hi, @ozanmk, the Netlify DNS is not working for this custom domain because DNSSEC is enabled for it and our DNS service does not support DNSSEC so all DNS queries fail:

$ whois | grep "DNSSEC"
   DNSSEC: signedDelegation
   DNSSEC DS Data: 22516 13 1 0F6A49630B319010F6A91FC6DA08A685049E521E
DNSSEC: signedDelegation

To resolve this either:

  • a) disable DNSSEC for this custom domain


  • b) stop using Netlify DNS for this custom domain

Those are the only two solutions for this issue at this time. If there are other questions about this, please let us know.

Thank you @luke, my registar disabled the DNSSEC.
Now I can verify DNS, but when I proceed with “provision certificate” I got “We could not provision a Let’s Encrypt certificate for your custom domain.” what should I do?

@ozanmk It can take anywhere from a few minutes to an hour or so for the DNS to propagate so that the certificate can be issued. Currently, neither Comodo nor Verisign knows about your DNS yet.

I’d give it more time … maybe check back tomorrow.

Thanks @gregraven. It works now.

1 Like