DNS issue with custom domain

Hi - Please help me with the deployment of my site using custom domain. I have reviewed the support guide on ‘Page not found’.

Netlify site - https://tender-davinci-2d2db3.netlify.app/ - works without any issue.
Custom domain - https://rujutasondur.com - does not work, either gives non existent domain or connection refused error.
I have a index.html in my /dist folder. However, I am not able to download the deployed files from the build. I get ‘error during download’.
I bought the domain from google domains, I had configured the name servers for the registered site using netlify DNS.

dig output
$ dig www.rujutasondur.com
; <<>> DiG 9.10.6 <<>> www.rujutasondur.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21676
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;www.rujutasondur.com. IN A
www.rujutasondur.com. 60 IN A
;; Query time: 36 msec
;; WHEN: Tue Sep 01 12:19:26 IST 2020
;; MSG SIZE rcvd: 54

@rmsondur Welcome to the Netlify community.

Did you add your customer domain name to tender-davinci-2d2db3.netlify.app? In the Netlify Domains dashboard for tender-davinci-2d2db3.netlify.app, you should see your custom domain listed. If not, you have to link the custom domain, which you seem already to have assigned to Netlify DNS, to the tender-davinci-2d2db3.netlify.app site.

Hi Greg - Thanks for the reply. Yes, I have already added the custom domain name to the netlify app. The custom domain (rujutasondur.com) is listed correctly. - Raghavendra

@rmsondur OK, but something still isn’t correct or your site would be loading. Can you provide more information about how you set up your custom domain?

@gregraven - As far as I recall, the process was straightforward. Under ‘Domain Management’, I had selected custom domain, after entering ‘rujutasondur.com’, I was prompted to verify if I am the owner. Netlify provided me with DNS entries to be added to Google domains nameservers, which I have done. Not sure what I missed. One possible problem - there could be a mismatch between domain owner (rujuta.sondur@gmail.com) and Netlify account holder (rmsondur@yahoo.com ??) but I don’t know how to verify this. Thanks.
Edit - I have renamed Netlify site from tender-davinci-2d2db3.netlify.app to rujutasondur.netlify.app for now.

Hi, @rmsondur, you also need to add the custom domain to the site settings under Site Name > Settings > Domain management > Custom domains.

You can see that setting when logged in here also:


If you add the custom domain there, this should help to resolve the issue. After adding it there, then scroll down and click the “Verify DNS” button. If that still doesn’t resolve the issue, please let us know.

@luke - I tried the option. I logged in to Netlify, I logged in rmsondur@yahoo.com to access the site. While adding custom domain, the verification question is asked if I am the owner. But I am not - it is rujuta.sondur@gmail.com. So it takes me back to the 'add custom domain question. BTW - I have created a support ticket to change owner of the site ‘rujutasondur.netlify.app’ from ‘rmsondur@yahoo.com’ to ‘rujuta.sondur@gmail.com’. Then both the owners of netlify site and the domain would be same. Let me know if I am doing this right.

Hi, @rmsondur, I believe this was resolved in another channel. If not though, please reply here again anytime.