"Check DNS configuration" for apex domain

Hi Laura, we’ve done all of this but it still doesn;t seem to work. Here’s the links to our set up on Digital Ocean and Netlify: https://jmp.sh/77pvBPN & https://jmp.sh/GXONfff

Got your certificate fixed, @edwardnewton.

Thanks for getting back to me Dennis, but I’m still not seeing www.cleanily.com…will this take time to propagate?

Hi, @edwardnewton. I’m showing cleanily.com and www.cleanily.com both returning the same site and both have a working SSL certificate (the same SSL certificate with a start date of Jan 12 13:28:33 2020 GMT).

If you are still seeing issues would you please send us the x-nf-request-id header for the non-working response?

Note, if this header is unavailable for any reason, would you please send us the data it replaces? That information being:

  • the complete URL requested
  • the IP address for the system making the request
  • the IP address for the CDN node that responded
  • the day of the request
  • the time of the request
  • the timezone the time is in

Also, if there are any questions about this reply, please let us know.

Hi Luke, the site is resolving fine, it’s just that cleanily.com should be redirecting to www.cleanily.com and it is not

I’m showing the opposite configuration under custom domains, which is that www.cleanily.com is set to be the primary domain and, because of this, cleanily.com redirects to the www subdomain above.

If you want www.cleanily.com to redirect to cleanily.com, please go to the site’s “Custom domain” settings in Netlify. Then click the “…” to the right of cleanily.com and then choose “Set as primary domain” in the dropdown menu. This should cause www to redirect the the apex/root domain.

If this doesn’t work (or there are other questions), please let us know.

Hi Luke, yes the configuration is correct, but that’s not what us happening. www is redirecting to cleanily.com. Should be the opposite

@edwardnewton, www is a 200 response when I test:

$ curl -svo /dev/null https://www.cleanily.com/  2>&1 | egrep "^< .*"
< HTTP/2 200
< cache-control: public, max-age=0, must-revalidate
< content-type: text/html; charset=UTF-8
< date: Mon, 13 Jan 2020 10:10:52 GMT
< etag: "3672bd61d5dc80e85139ccf98875b4c6-ssl"
< strict-transport-security: max-age=31536000
< age: 341
< content-length: 21160
< server: Netlify
< x-nf-request-id: 01076c51-cbe0-4b2c-92c4-900ecd7fd48f-1047765

And the apex/root domain is a 301 redirect to www:

 $ curl -svo /dev/null https://cleanily.com/  2>&1 | egrep "^< .*"
< HTTP/2 301
< cache-control: public, max-age=0, must-revalidate
< content-length: 41
< content-type: text/plain
< date: Mon, 13 Jan 2020 09:23:14 GMT
< location: https://www.cleanily.com/
< strict-transport-security: max-age=31536000
< age: 3208
< server: Netlify
< x-nf-request-id: 9d54580b-8f57-4e45-a9cb-95f69ffbf2ed-7032841

Chrome hides the www in the browser address bar, but it is still there. We cannot control what Chrome shows though. Chrome also hides the https://. There are many things about Chrome I love but hiding the actual URL used isn’t one of them.

Thanks for explaining Luke, yes just checked in Firefox and all good, cheers.

We are also experiencing the same issue with our apex domain – aceanalytical.com. The client manages the DNS through JustHost. The CNAME record we created for the ‘www’ subdomain works and was Verified in the Netlify dashboard. However, we tried a CNAME (Alias) record the apex domain and is didn’t work. Currently we’ve configured an A record for the apex domain pointing the Netlify server IP and it’s not working/propagating either. Any suggestions?

HI, @deepspaceprogram, and welcome to our Netlify community site.

I’m showing both the www subdomain and the apex domain (aceanalytical.com) working for the Netlify site when I test now.

Why didn’t it work before? My best guess is that the previous records were being cached due to time to live (TTL) values in the DNS records themselves:

The only solution for this is usually to wait for the TTL to expire. There is more information about minimizing the impact of TTL values when making DNS changes here:

​Please let us know if there are other questions and/or if it still doesn’t work for you when you test.

@luke The same is happening to me now. My apex domain doesn’t load or redirect and I have a “Check DNS Configuration” warning, but the DNS records are the default Netlify ones.

Hi, @AAA, and welcome to our Netlify community site.

What domain name (or names) is this happening for?

You can private message (PM) that information to one of our support staff and I’ve confirmed that PMs are enabled for your community login. Note, that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

Hi, @AAA, thanks for sending us the domain name. There was an issue on our side which has been corrected now. Both domain names (the www subdomain and the apex domain) work now when I test.

Would you please confirm the issue is resolved when you test now as well?

Hi @luke, I’m also having the same issue as the original poster where the dns for my domain www.brandonpugh.com appears configured correctly but I’m seeing the Check DNS configuration message.

Hi, @bpugh, and welcome to our Netlify community site.

I showing the www subdomain working:

www.brandonpugh.com.	1799	IN	CNAME	brandonpugh.netlify.com.
brandonpugh.netlify.com. 19	IN	A

However, the apex/root domain is pointing a server not controlled by Netlify:

brandonpugh.com.	1799	IN	A

We have documentation about this here:

If your DNS service doesn’t support the special record types, then please change that A record to point to the IP address instead of the one above. (If the special types are supported, please use those.)

If there are other questions about this, please let us know.

Not sure how I messed it up but it looks like I needed to add an ALIAS record instead of the A record. Thanks a bunch for the help @luke!

hi bpugh, does that mean the issue is fixed now? Can we close this ticket?

Yep all good now! After I fixed the DNS records I also had to renew the SSL cert to include the apex domain but it is redirecting properly now.