"Check DNS configuration" for apex domain

My domains are acting weirdly - I changed the DNS nameservers two days ago from google within domains. I believe I set them correctly:

The www.mostly.codes domain (set as primary) and mostly-codes.netifly.com are showing up as correctly set up, but the apex sub-domain-free mostly.codes shows a warning informing me to Check DNS configuration - I believe I have, and it has been well over 24 hours since the setup. Is there anything I have forgotten to do that would cause this issue?

Hi, @tobiasroland, it isn’t you - it’s us. There was an error for the root domain A record on our side which has been resolved now.

This wasn’t caused by anything you did and thank you for notifying us of this issue. We corrected the issue at Netlify and it is working now when I test.

If it doesn’t work for you or there are other questions, please reply here anytime.

1 Like

Hi @luke ,

I think I am having this same problem. I have set the nameservers correctly - https://whois.domaintools.com/foodzzon.com

But it’s still showing to check DNS configuration. Thank you for consideration. Let me know if I am doing something wrong.

Hi, @sanjitchak. I don’t show this domain configured for any Netlify sites.

For example, the URL doesn’t below work. It would if a) someone is logged in as a member of the team where is is configured and b) the configuration existed (but, again, it doesn’t).


I also don’t show this domain configured for any Netlify sites. Did you delete the configuration already?

Hi @luke,

I apologize for my mistake. It was completely my fault that I added foodzzone.com before, not foodzzon.com (I added one extra ‘e’ by mistake).

Thank you for your time.

Hi @luke,
I think I have the same issue with the domain. I have described it in this thread

Can you please take a look. Thanks

@brokeyourbike, I replied there just now.

I have exactly the same issue. https://jmp.sh/rIbfPLZ - and we created DNS CNAME record on Digital Ocean pointing www.cleanily.com to hungry-elion-334924.netlify.com - could someone have a look please?

Hi @edwardnewton,

In addition to the CNAME for your www, you need an A record for your bare domain. This post shows the IP address you’ll need for that record: [Common Issue] Can I host my site on Netlify but keep my DNS at my domain registrar?

Hi Laura, we’ve done all of this but it still doesn;t seem to work. Here’s the links to our set up on Digital Ocean and Netlify: https://jmp.sh/77pvBPN & https://jmp.sh/GXONfff

Got your certificate fixed, @edwardnewton.

Thanks for getting back to me Dennis, but I’m still not seeing www.cleanily.com…will this take time to propagate?

Hi, @edwardnewton. I’m showing cleanily.com and www.cleanily.com both returning the same site and both have a working SSL certificate (the same SSL certificate with a start date of Jan 12 13:28:33 2020 GMT).

If you are still seeing issues would you please send us the x-nf-request-id header for the non-working response?

Note, if this header is unavailable for any reason, would you please send us the data it replaces? That information being:

  • the complete URL requested
  • the IP address for the system making the request
  • the IP address for the CDN node that responded
  • the day of the request
  • the time of the request
  • the timezone the time is in

Also, if there are any questions about this reply, please let us know.

Hi Luke, the site is resolving fine, it’s just that cleanily.com should be redirecting to www.cleanily.com and it is not

I’m showing the opposite configuration under custom domains, which is that www.cleanily.com is set to be the primary domain and, because of this, cleanily.com redirects to the www subdomain above.

If you want www.cleanily.com to redirect to cleanily.com, please go to the site’s “Custom domain” settings in Netlify. Then click the “…” to the right of cleanily.com and then choose “Set as primary domain” in the dropdown menu. This should cause www to redirect the the apex/root domain.

If this doesn’t work (or there are other questions), please let us know.

Hi Luke, yes the configuration is correct, but that’s not what us happening. www is redirecting to cleanily.com. Should be the opposite

@edwardnewton, www is a 200 response when I test:

$ curl -svo /dev/null https://www.cleanily.com/  2>&1 | egrep "^< .*"
< HTTP/2 200
< cache-control: public, max-age=0, must-revalidate
< content-type: text/html; charset=UTF-8
< date: Mon, 13 Jan 2020 10:10:52 GMT
< etag: "3672bd61d5dc80e85139ccf98875b4c6-ssl"
< strict-transport-security: max-age=31536000
< age: 341
< content-length: 21160
< server: Netlify
< x-nf-request-id: 01076c51-cbe0-4b2c-92c4-900ecd7fd48f-1047765

And the apex/root domain is a 301 redirect to www:

 $ curl -svo /dev/null https://cleanily.com/  2>&1 | egrep "^< .*"
< HTTP/2 301
< cache-control: public, max-age=0, must-revalidate
< content-length: 41
< content-type: text/plain
< date: Mon, 13 Jan 2020 09:23:14 GMT
< location: https://www.cleanily.com/
< strict-transport-security: max-age=31536000
< age: 3208
< server: Netlify
< x-nf-request-id: 9d54580b-8f57-4e45-a9cb-95f69ffbf2ed-7032841

Chrome hides the www in the browser address bar, but it is still there. We cannot control what Chrome shows though. Chrome also hides the https://. There are many things about Chrome I love but hiding the actual URL used isn’t one of them.

Thanks for explaining Luke, yes just checked in Firefox and all good, cheers.

We are also experiencing the same issue with our apex domain – aceanalytical.com. The client manages the DNS through JustHost. The CNAME record we created for the ‘www’ subdomain works and was Verified in the Netlify dashboard. However, we tried a CNAME (Alias) record the apex domain and is didn’t work. Currently we’ve configured an A record for the apex domain pointing the Netlify server IP and it’s not working/propagating either. Any suggestions?