Cannot provision cert because domain "doesn't appear to be served by Netlify"


I deployed a site that I have deployed here at Netlify before. I attached a custom domain to it, one that I have used in the past, so the nameservers had been set up months ago. When I did this, the DNS doesn’t seem to be recognized, even though the custom domains work. However, because its not being recognized, the UI isn’t allowing the cert to be generated. The domain is one of the domains that requires HTTPS, so this prevents me from using the site at the custom domain.

I would prefer not to share the domain publicly as it is a test site and I would rather keep it private. If you could send me a message directly, I can share it that way.

I went through the troubleshooting options, and when I run the CURL command in the docs, I get “Server: Netlify”, so I am sure the domain is set up and not cached, etc. We do not use this domain otherwise, only when deploying to Netlify for testing. I’m not sure what else to do at this point. The deploy seems to work fine, I just cannot get the domain to be recognized by Netlify to issue the cert.


I think there is an outage or some bug that is occurring. I’m experiencing the same thing on all of my sites:

Renew certificate with Let’s Encrypt
DNS verification failed
[mysitename] doesn’t appear to be served by Netlify

Hopefully we can get this resolved quickly!

Thanks Darcy. I was hoping to use the site at our url later today… the domain appears to be configured as I can access it that way and still get to the site. Would it be an option to set up a custom cert in the meantime?


Is anyone else experiencing this issue? Seems like a critical one to me. We can’t register new domains.

hi there, we don’t have any widespread outages that are at play here - this does seem to be a configuration issue for both of you.

without knowing which domains/URLs this is regarding i can only give generic advice, but i feel sure that there is some relevant guidance in here:

I’m also seemingly getting the same issue on multiple sites on my Netlify account. One of which has been running on here for a long time and is now suddenly showing “Check DNS Configuration” on all of the custom domains.

The site still works as of now but it won’t let me renew my certificate and states “ doesn’t appear to be served by Netlify”.

However I have another site which has been setup recently and I’m not able to generate a certificate for it at all because of this same issue, but accessing the domain under http does take me to the Netlify site.

1 Like

Hi perry, thanks for the reply. I have around 20 sites set up and some of these have maxed out on domains, and this was all working yesterday, so I’m certainly confused.

One of the sites is

We have one domain set up at

In AWS Route53 we have the CNAME of that domain pointing to

But now I am seeing this error in the Netlify console:

Check your domain’s name servers

Log in to the account you have with your domain provider, and make sure your name servers are set to the following hostnames:

I did not have to set Name Servers before, only the CNAME setup.

And now I cannot renew the cert because of the error * doesn’t appear to be served by Netlify

But the site is still up and running now with the previous cert, that is gonna expire eventually, but more critically I cannot add new domains to our production setup.

Are you sure nothing changed on the Netlify end?

Thanks for chiming in Nathan. Clearly there’s a wider issue at play here…

Just to add a bit more ground to this issue, I’ve just been in contact with a few others I know who use Netlify and they are also getting this “Check DNS configuration” message on their custom domains. Also prompted them to try and renew their certificates and are getting the “x doesn’t appear to be served by Netlify” message upon attempting.

3 out of 4 of my sites running on Netlify have this issue currently, plus a few others I know, definitely seems like there’s some wider issue going on here…

As a note - if this is production-critical for others as it is for me, Vercel has a setup that is quite similar, and my testing environment is now up there and running smoothly. Took no time. For now I’m going to set up any new clients there since we can’t get SSL working with Netlify.

As far as I can tell, @darcy , you have and had things misconfigured, which is why you saw the error

Specifically, you set up our DNS hosting, which is what that error message was talkign about - you configured it on our side but did not configure it at your registrar. Probably you did not mean to, but you did, and it is still configured here: Netlify App

If you delete that and then change your CNAME back, things will work fine and no error messages will be shown.

But anyway, this wasn’t a bug but instead a misconfiguration.

@NathanWild if you’d like to let us know which sites you are struggling with we’ll be happy to take a look and advise.

I am having the same issue. The domain is

I am seeing Server: Netlify in the CURL command.

I have also checked that the DNS has propagated using DNS Propagation Checker - Global DNS Testing Tool

I am using an A record.

Thank you!

  • Robert

Hey, thanks for the reply,

I’m getting this issue on 3 of my sites, they are the following:

  • lilchiefrecords-preview (
  • nathanwild ( and
  • jackcana (

All of which are displaying correctly when visiting, but doesn’t let me renew or create certificates for them. I’ve never used “Netlify DNS” for them and not ever had an issue.

The latter two have been online for a fairly long time and do have SSL certificates currently, however the first one had its DNS setup yesterday and is fully propagated (I’ve checked with

thanks for that info! we are taking a closer look at the situation, and will let you know as soon as we have information to share.

please keep the details coming, they are helpful.

Hi I’m also experiencing unusual and unresolvable issues around DNS verification. I created a new site and was mapping a custom domain like I’ve done literally hundreds of times but it won’t resolve after a few hours. I’ve used a DNS checker and confirmed my CNAME record is correct. I’m assuming this is an unreported outage. WIll follow this ticket, thanks.

Hi there, thanks for chiming in. You’re saying that I need to delete the DNS zone entirely?

That seems strange. It was added 4 months ago, and we haven’t had any issues until today, and we’ve been adding sites and domains plenty since then…

It can’t be a coincidence that we’re all chiming in with new concerns today, can it?

do you have a site we can check, resto? we are on the case, something indeed does seem up and we are investigating now.

Hi, I just started pointing a domain to Netlify yesterday. It started out working no problem, but today I am having the same issue as those above "domain doesn’t appear to be served by Netlify”.

please hold, darcy. we think the problem might be something else. this error does occur “naturally” in response to config errors but this current situation is indeed unusual, we are investigating. stay tuned.

1 Like

Hey Perry here are the details:

Netlify Site:
Custom Domain :


1 Like