Builds are not deploying latest changes

We’re experiencing some issues with our builds as some seem not to be deploying the latest changes to their equivalent branch/permalink builds.

For instance, these two branches have exact the same codebase, but the second hasn’t deployed the latest changes:

Is this a known issue? We’ve tried redeploying on top of them but nothing seems to trigger any updates. Maybe caching?

I appreciate any insights into why this is happening as this is affecting us releasing any updates to the live website.

Hey @website-devs

Branch deploys are not automatically published to the production site. Only builds on the main production branch are automatically deployed to the production site. See Branches and deploys documentation for more.

Hey @coelmay,

Sorry, I might have not been clear enough on my explanation.

I understand the branch deploys concept (we’ve been using Netlify for a few years now). The issue was that, even after building a new deploy based on changes made to that branch, the Netlify URL would not show those changes.

Putting it simple, let’s say I changed the h1 on one page from ‘Hello’ to ‘Hello there’. We can see Netlify build deploying against that branch, just as normal, and having a success build in the end. However, if we would click on the “Permalink” of that build, or if we would go directly into that branch url (, the h1 would still show as ‘Hello’ only.

We did manually trigger other deploys on top of that, using the deploy hooks, and the same thing would happen. Netlify builds the whole thing just normally, but in the end the changes are not there.

Funny enough, we merged the same changes into another branch (exact same codebase/configs/etc), and this time we COULD see the latest changes on both the permalink and the branch Netlify’s URL.

After hours of frustration, one of the builds finally/eventually updated these URLs. One thing that comes to mind is some sort of caching mechanism from Netlify’s url that didn’t work and didn’t cleared the cache of previous builds.

It has delayed our whole release plan. Could you please look into it?

To clear any confusion, I am not a Netlify employee, I am a community member.

I have seen/heard of instances where new content is not pushed to the CDN and a manual purge is required (relatively rare though.)

Are you auto publishing on the main branch? Do you have a service worker on the site (as they can impact loading new content)?

As the site is password protected it is impossible to test anything.

I did get confused indeed! My apologies, and thank you for your support. :slight_smile:

How can I manually purge Netlify’s CDN?

No service worker. We do have auto publishing on the main branch - could that change anything?


hi there, looking at the deploy history on the deputy site, i see some issues (screenshot is from main branch)

what is this plugin that keeps cancelling builds? it doesn’t seem to have the same problem on staging:

this feels a bit like a configuration issue and/or an our of sync dependency, not so much a cache problem. i’d probably start by comparing the two branches in detail to try and figure out what part of the config/setup is not the same.

1 Like

Hi @perry,

These are not issues. We have a plugin that does some checks on whether it should skip the build or not. Perfectly normal and aligned to what we have been using for over a year now.

Our issue is that code changes are not reflected in the deploy. Let’s say we added a new <h1>Test</h1> to our homepage and deployed that. Netlify will build it succesfully, but the <h1>Test</h1> would simply not be there in the deploy Permalink url (eg: or Branch deploy url (eg: It simply ignores any changes made and shows the outdated version instead (like the cache wasn’t cleared, or it’s simply pointing to the wrong (old) destination.

This has been a huge issue as we can’t trust the build would actually deploy our changes, and we have to constantly try to re-trigger it until it eventually “clears the cache” or triggers something else that works.

Could we please have a look into it?

The links you provided are password protected. No one can see what is or isn’t there.

@coelmay the links are not that relevant, really. They can’t tell much of the story, it was more to illustrate the kind of urls I was referring to (permalink and branch deploy). The main issue is that the the changes do not show on new builds. Is this something someone else has experienced as well?

We have also noticed that the issue might be happening when we call the netlify build hooks, so this might be related.

Hi @website-devs

this is not expected at all. Can you make a reproduction case of this and share us the links to investigate?

we would need:

  • a permalink pointing to a build with some change
  • the change you want to see visible (pointing us to a build where that change is visible for example).


Hey, I have exactly the same problem, in front of my url it is attaching main-- and url it is main– unstead of
It is auto deplyoing from main banch in github
I have made some styling fixes and push it about 30 mins ago

main is just the branch name. would always be accessible.

Happy to take a look if you wish to share the URL.

Cheers, I’m having the exact same issue – commits to „testing“ don’t get deployed. Can you please have a look at it? The site would be:


OK. At the moment, I see that is serving your current most recent deploy on that branch:

So, what we ask when you say “isn’t deploying the latest content” is that you download a copy of the deploy from this link (from this page):

…and then confirm that a build of the same commit does or doesn’t build into the same files locally, once you’ve synced up all the versions locally with the versions we use: [Support Guide] Debugging Netlify site builds

If so, then we’ll be able to help debug what is being served! If not, then you’ll debug what is being built, instead :slight_smile:

Hey fool, thanks for your help! It seems to have sorted itself out – new commits to testing deploy as they should. Maybe caches didn’t get invalidated or something. Thanks anyways!

thanks for coming back and confirming your problem was solved @js32

1 Like

Okay… now it doesn’t work again with this site:
Latest changes to style.min.css don’t appear to make it into the build.

The downloaded zip-files contains the changes but the site served does not.

Hi @js32 , sorry to hear about the continued trouble! Could you share what changes were made to style.min.css and how we can see if the changes were built/served?

Hey, thanks for your reply. At the end of style.min.css should be the following:



.orderz {
  justify-content: center;

.orderz * {
  align-self: center;
  margin: 0;
  text-align-last: center;

.bestellform .form-group {
  margin-bottom: 0;

.bestellform p {
 margin-bottom: 0;

.preis p {
  line-height: 1.2;
  font-size: 10px;

.carousel-control-next-icon, .carousel-control-prev-icon {
  background-image: none;
  width: unset;
  height: unset;
  color: #ccbf98;
  font-size: 40px;


.carousel-control-prev-icon:before {
  content: "<";

.carousel-control-next-icon:before {
  content: ">";

  .carousel-control-next, .carousel-control-prev {
    width: 9%;

This is a screenshot of my developer tools:

OK, and you’ve tried my prior advice? Downloading the deploy in question, comparing it to your local build to confirm that things are identical in the output of the build, and debugging that problem if not?

That’s the debugging we need you to do before we can help you, still, just like last time you asked :slight_smile: