Home
Support Forums

Branch subdomains not working after I changed deploy repository

Hello all,

The branch subdomains deploy isn’t working correctly for me since I changed the build repo.

In Domain management --> Branch subdomains, I only see the branches from the old repo and cannot select the branches from the new one.

Is there something I missed out ?

Cheers,
Nicolas

The last time I used branch deploys, I wasn’t getting any branches in the list, however, I still went ahead and entered my branch name and it works. Did you try that?

The list shows me the branchs from my old repo.
If I try to manually enter a branch from my new repo, I just have a message saying “No result found” but I can’t go further.

Weird. It just worked for me. I added a non-existent branch name and it accepted it without any issue.

Just to avoid confusion; I’m adding the branches here:

After that, you need to go to Domain management --> Branch subdomains and select the branchs you want to deploy.

Not ideal but have you tried creating a new site with it linked to see if they work there? It could be that a bug needs to be filed when changing repos this occurs.

I created a new site and it worked. I’ll keep this option and forget about my old site.
Thanks!

1 Like

Cool, glad you got it fixed quickly!

Keep safe!

Thought I’d update you with a little bit of testing, if you make a change to the branches you’re trying to deploy, then deploy after you’ve added them to the deploy context they will appear. A bug I am going to report is that the old branch subdomains remain linked to the old repo.

Thanks again!