Weird situation on multiple Sites. Index page not updating

Hi all,

I have a weird situation that I cannot figure out. I have two GatsbyJS sites

I have put a new post on both (the first of this year I believe). The posts are not showing on my index pages, they are there as I can access them from the URL. When I build and run locally they appear as the latest post as expected.

Everything appears to be OK, Netlify builds the sites just fine. At first I thought this was a caching issue but I have ruled out client cache as I have tested with multiple browsers, devices and people. Including dumping local cache.

Here is an example
UIBuzz Podcast - Episode 8 - NextJS First Moments | Blog (

Yet you will not see it on the index.

Thanks for any suggestions. Weird that it’s happening on multiple sites and only on Netlify host.

@GrfxGuru I see two posts on your peterwitham site dated this year, and one on the computeswift site dated this year. Perhaps you are seeing an issue due to local caching?

OK this is very weird, maybe my local network is up to some shenanigans:)
So glad everyone else is seeing it right though.
Thanks for checking and appreciate the feedback!

Ok my bad, I forgot that I had posted those, they are showing correctly but I have at least one post that went up today on so there does appear to be an issue still.

I’ve solved the problem I think, not certain that it’s my solution but it worked. I toggled the auto publish a couple of times.


Hi, @GrfxGuru. You might also want to check to see if the incorrect responses came from Netlify or from the site’s service worker:

The site for the domain is using a service worker so that could have been part of the issue. If you see any further issues, please let us know.

1 Like

Thanks Luke, I’ll look into it.